WD_backup share not found

Hello all

My product is MyBookWorld(MBW) 1TB updated to the latest firmware, to work with Mac OSX Lion.

I have been trying to get the timemachine to make a proper backup of my macbook pro. I have suceeded to make one complete backup, but not after that.(I checked through ssh and there is a sparsebundle present)

The main problem is that the WD_Backup share keeps falling out. It´s not visible in Finder, or makes a short apperance before dissapearing again.  The time machine keeps saying it cant find the share. Now it´s been away and not even giving the huest appearances anymore. 

The other share is usually present, the one called MyBookWorld.

Here´s what i´ve done upto now:

  1. I have tried to reboot computer and MBW. The WD_Backup shows up for a few minutes before dissapearing.

  2. I have enabled ssh, and logged on. Someone suggested to delete a file called something like AppleDB, and that made my WD_Backup show up again. I did an incremental backup, or started to without completing as the share dropped out again.

  3. Someone suggested to rebuld some stuff in twonkymedia from the webadmin, and i´ve tried that without luck.

  4. I´ve tried to logon to the WD_Backup from finder whenever it shows up, but i´ve never been successful.

I don´t really understand this. It should work without me spending hours on the internet, trying out different hacks?

Any suggestions, please?

Thanks, Frost

Check this thread, there are still a lot of problems related to the MBW and Lion.