WD Backup Setup doesn't find drive

I have a 1 TB WD Passport which previously was backing up my data via WDSmartWare, however the software will no longer open. When I looked it up online, the info says it doesn’t work with MyPassport, which is a bit of a mystery since it used to. (And I have an old backup on the drive to prove it.)

So per the instructions, I installed WD Backup. However, it isn’t finding the drive. It only offers Dropbox. I’ve checked the steps in “WD Backup does not see my drive.”

OS in Windows 10.

Suggestions please - regarding either WDSmartware or WDBackup. Thank you.


I had similar problem. Tried to switch to WD Backup and it worked but doesn’t have the same features as SmartWare. I downloaded latest SmartWare Pro. (Ver Pro may require a certificate of some kind ($$). Anyway it finally worked and still does. Check under Settings in SmartWare for your version.

Also, there seems to be two WD Backup packages. It you look under Services in Computer Management (Local), there is WD Backup described as WD SmartWare Backup Engine and no WD SmartWare listed.

So, I suggest trying to download WD SmartWare.