WD Backup Settings won't open

Just noticed that our WD Passport Ultra hadn’t done a backup since last year! :scream:
When we try to open WD Backup Settings, or select “Backup Now”, nothing happens.
We’ve downloaded the software, uninstalled it and re-installed it, but the problem remains.
Is this a known issue. It has completely wiped the entire purpose of having this software and, ultimately, this drive. We really don’t want to have to get back into manually dragging and dropping stuff.
Please help WD. Thank you.
NJ

I found the same issue today. I tried restart the computer, uninstall and reinstall. Still won’t lunch.

It would be nice if WD acknowledged this issue, and attempted to provide some support on it.
Can’t say I’d purchase another WD product, based on the problems with the backup software.
How could you ever be sure that your backups are being done? :S

Hi, I have the same problem too, still no solution?


Appvalley TutuApp Tweakbox

No, and nothing from WD at all.

We’re having to drag and drop from local drives to the backup drive whilst we wait for a better drive/software to arrive.

This was my first, and will be my last, purchase from Western Digital.