WD Backup not launching

Until recently WD Backup has worked fine with my My Passport 3 TB drive. Now it will not launch on my PC. It works fine on my laptop, backing up the laptop to the same MyPassport unit. I reinstalled WD Backup, having downloaded the latest version. It still doesn’t launch. I have rebooted the machine multiple times. ???

Hi wspooner,

Your PC is running which version of Windows?

Also, Open the Services panel. Please follow the steps below for assistance.

1- Click on Start (Windows logo) at the bottom-left of the screen
2- Type msc from the search bar
3- Click msc application

Ensure the WD Drive Manager and all WD Services are running and set to Automatic.

  • WD Backup
  • WD Backup Drive Helper
  • WD Backup Snapshot
  • WD Drive Manager

Hi Alex
I apologize for not getting right back to you. I was away last week. I’m
on Windows 10.

Helper and Snapshot were in fact not running. I started both, setting them
to Automatic. It still doesn’t launch. I rebooted the machine, with no
difference. I did it again, still no luck. I double-checked that all 4
services are now running.


Hi wspooner,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support if you are having trouble with the form.

Will do - thanks.

Just bought a 8TB easystore and having the same problems with WD Backup. Spent three hours on the phone yesterday with WD tech support group. They got it working after doing some stuff but when I restart the computer WD Backup doesn’t work. Both techs uninstalled and installed WD Backup without success. There are problems with the software. Running Windows 10.

1 Like

Same exact issue. Any luck form anybody else? I’ve tried the same thing in terms of rebooting, uninstalling, reinstalling, starting services, etc. Worthless product if the main app doesn’t work. Without the WD app working, its just a dumb USB drive.

1 Like

Same issue, I see tons of people with the same problem. IS WD doing anything to adress this issue?

Same problem for me. WD Backup was working fine, but now it won’t launch. I see that many people have uninstalled and reinstalled the software to no avail. Is WD even looking into this? I don’t see “WD Backup” on their list of downloads anyway, so maybe WD has stopped even supporting it? At this point, I would not recommend this product (WD Backup) or WD in general. Buyer beware!

I got this error but when I checked Windows EventLog I got some precision and this article helped me wd-backup-crashes-or-does-not-backup-anything

I just fixed this with the help of customer service.

Uninstall WD Security, WD Utilities and WD Backup through Control Panel. Reboot. Reinstall WD Backup from downloads page on WD website. Ta-da.


This has plague me for over two years. Finally figured it out. Go to:

C:\Users[Customer User Account]\AppData\Roaming\Western Digital\WD Backup\

Delete the .schedule file for each backup. Most people probably have just one file to delete, but there is one .schedule file for each backup you have setup. Deleting this file will not delete your backup schedule, a new .schedule file will be created when you open the interface via the tray icon or starting the program.

This allows you to run the program normally again without losing any progress or settings.