WD Backup doesn't recognize my drive

Recently, WD Backup gives an error when I am trying to initiate a backup - “Unable to backup files to My Passport. Please make sure your drive is connected and accessible.” However, the My Passport icon indicates that it is fine. Further, when I run the diagnostics from the WD Drive Utilities, it indicates that the drive is ok with a green check mark. Also, I can access all the files on the drive from Windows (10) File Explorer.

How should I resolve this issue.


Hi RogerGB2,

You can refer to the link mentioned below to resolve WD Backup issue.


Hi John15,

I have already been through the options suggested in the link that you provided. That link was already sent to me by WD Support. Unfortunately, it has not worked.


1 Like

I have the exact same problem as RogerGB2. I know that my McAfee Virusware has just expired, and my laptop is being protected by my Windows 10 security now. Since the link you provided mentions virus security, I could use some more specific config instructions for how to allow the WD backup.

I suggest you to try the below solutions & check if that works:

  1. Plug the drive into another USB port
  2. Change USB cable
  3. Change drive letter
  4. Reinstall USB controller
  5. Update WD device driver
  6. Run anti-virus software

Hope the above solutions helps to resolve the issue.

I too have performed all recommended procedures and My Passport For Mac will not backup.