WD Backup does not appear to update

I am currently using WD Backup version 1.0.5556.
To update the program I can download version 1.6.6060 to my PC without problem. I can and open the zip file without problem and when I double click the .exe file the new version seems to load.
However when I susequently check the version in “About” in the program it continues to show version 1.0.5556.
Does this mean I have not updated?

Any advice will be gratefully received.
Mike

Try completely uninstalling the program from Windows in the Control Panel (Programs and Features section). If you install the latest version from scratch (instead of updating from a previous version) it should not have a version conflict.

Thank you I have tried that and it has not worked. Although the installation process says that back up has been installed it has not. I have also tried reinstalling the old version without success.
Help

Sounds like something “Windozey” is broken.
You may need to repair Windows, but try this first.

Thanks but this didn’t work either.