WD Arcus App "Smart Connect" issue and fix!

I have a WD MyCloud PR2100 and i recently figured i would set up the Arcus app. Everything works aside from the mobile app. The on/off slider for Automatic Port Forwarding for"Smart Connect" menu under settings does go to on! So after scouring the web and calling support i finally figure it out. You need your EXTERNAL ip address in example 70.1.4.1:8081 not a local ip address such as 192.168.1.100:8081 or 10.1.1.100:8081. I couldnt get the automatic feature to work so finally i just settled for the manual option. I entered my External or WAN ip address and the port 8081 and voila! it works on the mobile app!

Also enable UPnP like the walk through says on your router! I added TCP/UDP exceptions for 443 and 8081

You just need to make sure you do a manual add for the server on the mobile app.

Helpful links:


Make sure your ports are open
http://www.yougetsignal.com/tools/open-ports/

1 Like

Thank you for sharing. This will help other Users in need.