WD Apps Installation Continuously Fails

Hello: I hope someone out there in cyberspace can help me.

I’ve never had any issue with any external storage – from other brands – and this time I just today bought a WD My Passport Ultra and cannot install it.

I’m really stumped and need help. I know this is long, though I’ve tried to explain fully.

I plugged it into my Toshiba Satellite and the “Found New Hardware” Pop Up stated that it could not find the driver. I “Ex’d Out” of that because the AutoPlay was also on the screen.

I choose to open files and then accidentally clicked on the WD Apps for Windows Folder and clicked on the application file named: dotNetFx40_Client_x86_x64 I went to do something else and came back to see I’d received a message about already having a newer version of .Net on my laptop. I realized that this was the wrong file and clicked on “cancel”.

I then went back and selected the WD Apps Setup to run the Wizard. I deselected the Smartware as I bought this for external storage/pw protection in order to copy most of my files before I re-install the operating system. I will then want to copy about half of the files back to the laptop.

Every time I try to run the WD Apps Setup I get the message that “WD Apps Setup Wizard Installation failed.”

And the details are:

WD Drive Utilities

Error 1603

Fatal Error during installation

WD Security

Error 1603

Fatal Error during installation

This unit appeared Under Device Manager, “Other Devices” (with a ? question mark) and under that, WD SES Device USB Device (Had a yellow triangle with exclamation mark)

So I followed the instructions in the manual found online under:

MY PASSPORT ULTRA USER MANUAL INSTALLING THE SES DRIVER – 74 Installing on Windows 7 and Windows 8 Computers After connecting the drive as shown in Figure 3 on page 5 or, use the Windows Computer Management utility to install the SES driver:

The Unit and driver now appear in Device Manager as: WD Drive Management devices, and under that WD SES Device (no ? or ! now)

BUT the WD Apps Setup still does not work.

I’m still getting the same error messages as in the beginning.

What do I need to do to get this to work. I need to copy my files to this drive (and be able to access them in the future). The store will not accept products that have been opened, even if they’re not working – and they will charge me way too much to diagnose the problem—on a product that was just purchased today yet doesn’t work.

My OS is Windows 7 Ultimate (have not used the bitlocker as my pc doesn’t have the TLP file required). I am using the latest version of Firefox, but have other browsers installed.

I’ve allowed WDC.com on all of them and have disabled all add-ons and extensions.

I also use Webroot Secure Anywhere and I think that Windows Firewall and Windows Defender are also running but don’t know whether I need to do something with these (or how) to allow this device to work.

I also want to create 2 or 3 different drives on this device in order to separate my files. I assume I need to do that before I copy any files as they will likely be erased upon partitioning. Correct?

I’ve searched the posts but don’t find this particular problem. It seems to me as though the installation file may be corrupted.

I haven’t gone straight to the WD Apps folder and tried to install by selecting the windows installer package as I was unsure if I should even do anything else at this point.

This is a lot of money to waste. Any suggestions as to what I can do? Please help if at all possible. In case I cannot get back to this site, can anyone send me their suggestions at:[Deleted] (no spaces of course and no ‘i’ in the word in)

Thank You!

Thank You!

Thank You!

Hi, you can download all of the available software for your Passport model from the download section on the support page. 


You can also follow the steps on the following link to partition your drive.


1 Like