WD Anywhere Backup Keeps Crashing


#1

It was working great last week, now it keeps crashing.  I’m not sure what I updated/revised/etc to make this happen, but now the software won’t even start.  When I try to start it, it just goes directly to the black window that has text which starts with “WD Anywhere Backup has encountered a problem.  We apologize…”

I uninstalled it and reinstalled the latest version.  Still does the same thing.  Any ideas?

Thanks

Barrett


#2

If the software keep crashing it might be issues with .Net. Please uninstall .Net 2.0,3.0, or 3.5 if you have them install might need to start with 3.5 and work your way backwards. Then just reinstall .Net from the link below, and that usually will fix any type of crashing. If that doesn’t work please post your system spec see the example below.

OS: Windows XP

HD: My Book Home

WD Anywhere Backup: 4.50.6354


#3

Greetings,

Have you reviewed / checked the System Event Viewer for possible errors or additional information?


#4

Nope.  How do I do that?

Windows XP, by the way.

As an update, the WD support folks told me that all I needed to do was uninstall the software and then reinstall it.  Gee, thanks for that.   (doesn’t work)

I tried uninstalling and then reinstalling various versions of .Net while also uninstalling and reinstalling the WD Anywhere Backup software.  Didn’t work.

I contacted Memeo support folks, and they told me that I just need to install their backup software – it’s the exact same thing as the WD Anywhere Backup, just a different label and slightly different look.  WD just packaged it with their name/logo/etc.  I did that, but now it’s asking me for a login ID and password.   Geesh.

B.


#5

Greetings,

The system event viewer is a component in Computer Management.  Get there by right-clicking on My Computer and select Manage (menu option).  Or, from the start menu under Administrative Tools.  Expand the Event Viewer heading in the left hand pane.  Then select Applications…  review the list of entries in the right hand pane.  Depending on the problem, error information might have been captured.  Entries are in order by date and time, this might help you isolate an error?


#6

I am having the same issue.  I’m on Windows Vista though.  Each time I try to start WD Anywhere Backup, I get a window saying “WD Anywhere has encountered a problem…”  One thing that might be helpful - in that error window, it asks if it can send the following error report to WD:

email: Not available
Problem Description:

Product Name: WD Anywhere Backup
Product Version: 2.0.0.0
CLRVersion: 2.0.50727.4200
OSVersion: Microsoft Windows NT 6.0.6002 Service Pack 2 (it says NT but I’m on Vista)
Build Version: 4.00.5484
Shutdown?: False
Platform: 32 bit
Backup Plan: 1
Backup Name: “JD_Backup”
   Destination: \MYBOOKWORLD\Public\My WD_Backup
   Secure: False
   Provider Type: Tanagra.FileCopy
   InstanceID: 260415C6-917D-4A52-BA66-AE48DBED16E5

Exception: Finisar.SQLite.SQLiteException: constraint failed
   at Finisar.SQLite.sqlite3.Throw()
   at Finisar.SQLite.sqlite3.sqlite_vm.Dispose()
   at Finisar.SQLite.SQLiteCommand.ExecuteNonQuery()
   at Tanagra.DataClad.MessageQueue.SQLiteMessageQueue.DoCleanup(SQLiteConnection conn)
   at Tanagra.DataClad.MessageQueue.SQLiteMessageQueue.Cleanup()
   at Tanagra.DataClad.MessageQueue.SQLiteMessageQueue.Init()
   at Tanagra.DataClad.MessageQueue.SQLiteMessageQueue…ctor(String dbPath)
   at Tanagra.DataClad.EngineController.Init(String pathToConfig)
   at Tanagra.DataClad.EngineController…ctor(String pathToConfig)
   at Tanagra.BMU.BMUEngineController…ctor(String pathToConfig)
   at Tanagra.BMU.BackupControllerServiceWrapper.Init()
   at Tanagra.BMU.BackupControllerServiceWrapper…ctor(Int32 port, String name)
   at Tanagra.BMU.BMUService.Init(Int32 portOverride)
   at Tanagra.BMU.BMUService.OnStart(String[] args)
   at Tanagra.BMU.BMUService.DoOnStart()
   at Tanagra.BMU.Tools.BMUMonitorShell.AttachToBackupController()
   at Tanagra.BMU.Tools.BMUMonitorShell.BMUMonitorShell_Load(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ContainerControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at Tanagra.BMU.Tools.BMUMonitorShell.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
App: SQLite.NET

Any clues?


#7

Once you install the software, try launching the software agian and check if get the error message, if yes then don’t uninstall the program. rather try to install it again and you will get an option to repair the software, Try repairing the software and check what happens.

Merry Christmas.


#8

I haven’t tried uninstalling or reinstalling.  Am I correct in saying you think I should try to install without uninstalling and then choose the option to repair the software?

More data regarding the problem:  I had to create a new user on Vista to solve an unrelated problem, and when I login as that user WD Anywhere Backup starts up fine.  This is not a solution for the WD Anywhere problem as all my data is still under the original Vista user and I do not want to solve this by moving everything over to the new user.

JD


#9

HI All,

Well, I figured out a sort of solution, but it’s like the one that the last user posted.  Just a debrief of what transpired thus far.  I’ve written (emailed) to both WD and Memeo.  Neither offered any explanation whatsoever of what could actually be the cause of the problem.  WD’s response was basically “uninstall and then reinstall” – despite the fact that I told them that this doesn’t work.  Memeo’s response was “install Memeo Backup, because it’s the same as the WD Anywhere Backup.”  I did that, and yes, it ran fine.  However, I still wanted to know why WD Anywhere Backup wouldn’t work.

I found out that although it wasn’t working for my original user account on my laptop, it was working fine on another administrator account that I had set up on the machine.  What caught my eye was the error message that WDAB was giving me when it crashed.  It said “WD Anywhere Backup is already running.” in one window, and then another window would tell me something like “it won’t run here because another user already has it running”.  So, I uninstalled the software and then logged into the other administrator’s account and reinstalled it.  Then, when I logged back into my original user account, the software worked fine!

Go figure.

Barrett


#10

I have the same problem  on the Windows 7 Professional x64. The WD Smartware does not  start and gives the dame 

exception error as shown above Finsair SQLite exception. This appears to be a problem with retrieval of data using SQLlite.

I have MS working on the issue but don’t know if this is a Windows 7 OS problem  with >net Framework or A WD Smartware softyware glitch? 

Any possible solutions would be appreciated

Thanks


#11

My recommendation would be to do what I described in the thread entry above yours:

1.) Create another user account on your computer.

2.)  Uninstall the WD software

3.)  Log into the other user account, and reinstall the software from that account

4.). Log back into your original user account, and the software should then work.

Barrett


#12

Barrett,

Your recommendations solved the problem in my new account but the problem still existed in the old account. after the reinstall of the WD Smartwae software. This also solved a problem i had with the catayst software for my ATI Radeon graphics card.   

In my case I just deleted the old account…

Thanks again for your help. 


#13

For me the same issue but i can not delete the old account because i need him.

does anyone have a better solution?  


#14

  For me, it was something to do with my backup plan.  I removed the contents of the \Application Data\WD directory, and it fired right up.

   Good luck!

    Brian


#15

I’m having a similar problem- WD anywhere keeps crashing my Windows 7 machine. Anyone have any ideas?

Is the memeo backup software free or did you have to buy it? I couldn’t find any free options other than a temporary trial.

Thanks.