WD Anywhere Backup interfering with Photoshop permissions

Hi.  When I have my WD Anywhere Backup drive connected to my PC, I get error messages when saving out Photoshop files. I have never had this problem on any other computer and this is the only one that I run my WD drive on. I basically get a message saying that “the file is locked or I don’t have the necessary access priviledges”.  I am the administrator, the only user of this PC and the files aren’t locked.

I have to get round this by saving out to the desktop and when I get the message again, I have to save back to the original folder. The previously saved file always disappears on it’s own when I save to a new location. Sometimes I’ve opened and closed to folder before saving the file to a new location and the file I have open isn’t even there.

On  few occasions I’ve saved the file, closed it and it’s disappeared from my computer altogether: because I didn’t open and close it’s containing folder to see if it was still there. It’s worrying because these are huge files which involve hours of work. Also,  when I need to purge deleted files, I can’t be 100% sure that I may be deleting backups for files which have mysteriously been deleted from my PC HD.

To get around this problem I inititally tried pausing the backups instead of disconnecting the drive, but  the log still read that working  files that I had open “could not be backed up because they had been deleted”.

Current work around: When I disconnect the WD I haven’t had this problem yet, so instead of being able to back up my work as I go, I’m having to work with the WD drive off and reconnect to it at the end of the day with all my files closed. This also means that  I can’t use the function which allows me to return to an earlier saved version of the file, made on the same day.

I spoke to Adobe about this and they don’t think it’s a problem with Photoshop  CS5.

Well this issue can occur if two programs are accessing the files at the same time on Windows

this should not happen with all the files, only with the ones that are been backed up at the moment

what type of drive you have?


Sorry I didn’ tget back to you earlier, I didn’t get any email notifications that I had a reply.

The details in my device manager are as follows: WD My Book IEEE 1394 SBP2. 

I hope that helps.