WD Anywhere Backup - Cannot restore!

I have an iMac and the HDD died…  This got fixed and am now trying to restore files that had been backed up using WD Anywhere onto a WD HomeBook. 

Using latest 2.5.127 version of WD Anywhere.

When I go to Restore, I get to the Select Items to Restore window.  However, it just says on the bottom of the window “Refreshing” and this has been at least an hour and I still don’t see any files in the window to select to restore. I have even tried restoring only Address book, but the same thing happens: an endless ‘Refreshing’. I can see the files in Finder, so I know they are there… Do I have to do this manually?

Please can anyone help???

Just go to the backup folder

I think is called memeo or something like that

It has been years that I don’t use that software but it worked well :smiley:

Just go to the drive and doa a simple serach for one of the known file which you might have backed up then you can track down the parent folder where it is sitting at present…

As long as the drive is not formatted or CLEANED this trick will help you…