WD Air for Mac not showing and unable to be erase

Hey guys,

So, I bought my WD passport Air (500G) running on Mac 10.9.5, at the end of the year 2014. worked perfectly.
yesterday I plugged it and it didnt showed up nether in desktop on in finder I was shocked losing my files. so I tried many time it didnt. so I gave up I knew it wont work as this the second time happen to me with WD products you just pay couple of dollars for products and it get damage even if you pay much attention to keep it save!
so pulled the WD utility and tried to scan and it wont complete the scanning. finally I came to erase it and it wont complete it. I left it for 10 hours to complete the erase it wont work. plus I tries the Desk Utility of Mac but it doesnt showed up! I need to find the problem please! Im very pissed I have all my photography and backups and music projects important things there and I lost it now and I dont want to loose the WD either. please what would be the problem!


Have you tried a different USB cable or port? Also you can try on a different computer to see if it helps.

Thanks ArMaK for replay!
Yes I did tried another usb cable, and it was the same result!
I tried plug my WD air through Belkin multiple USB ports powered one and is the same!
My issue is now formating the desk, but it wont do a complete formating! It gets till the middle and stops!


Try to run First Aid on the drive to see if the unit has any errors or if the test goes through correctly , you can also try to reformat the drive on a windows PC just to test.