WD Advanced Format Hdd and Linux NOT SOLVED?


#1

Hallo. I use a WD15EARS-00Z5B1

I tried AADAMOWSKI 'S parted method:

GNU Parted 2.2Viene usato /dev/sdbBenvenuti in GNU Parted. Digitare "help" per l'elenco dei comandi.(parted) unit s (parted) mklabel Tipo dell'etichetta del nuovo disco? gpt (parted) print Modello: WDC WD15 EARS-00Z5B1 (scsi)Disco /dev/sdb: 2930277168sDimensione del settore (logica/fisica): 512B/512BTabella delle partizioni: gptNumero Inizio Fine Dimensione File system Nome Flag(parted) mkpart Nome della partizione? []? Tipo di file system? [ext2]? Inizio? 64 Fine? -1 Avviso: È stata richiesta una partizione da 64s a 2930277167s. La posizione più prossima disponibile è da 64s a 2930277134s.È accettabile?Sì/Yes/No? yes Avviso: La partizione risultante non è allineata correttamente per garantireprestazioni ottimali.Ignora/Ignore/Annulla/Cancel? ignore (parted) print Modello: WDC WD15 EARS-00Z5B1 (scsi)Disco /dev/sdb: 2930277168sDimensione del settore (logica/fisica): 512B/512BTabella delle partizioni: gptNumero Inizio Fine Dimensione File system Nome Flag 1 64s 2930277134s 2930277071s(parted) quitInformazioni: Potrebbe essere necessario aggiornare /etc/fstab.

WTF??? Why parted tells me that the partition is not correctly aligned? Does anyone had the same issues??


#2

OK I am not a parted user as I prefer to use fdisk.

Usually, incorrectly aligned partition message I think means that the partition sector start is not on a 2^x number boundary; i.e.: It is possible that whatever size you requested the partition be, now calculates out to be not on the beginning or end of any sector (but somewhere within it).  With all the latest drives there are two things to keep in mind.

1> The sector size may no longer be 1024 size, (Linux filesystem notes point out that some drives now operate at 4096).

2> The sector border (beginning of a sector) depend on the drive layout & its internal comfiguration.  At times even the manufactures special “on-drive management firmware”  and user application can play around with the physical drive layout. With usually is a great help to tune systems for the best power/performance.

I would suggest that you use /sbin/fdisk (as super user) and:

i.e.:  “/sbin/fdisk /dev/sdb”

1> Remove any partitioning table data currently on the drive so your got a clean partitioning table to work with.

2> Create the partitions as you require by using the “+nG” where the “n” is for the number of Gigabyte size. Of course you can use other size nuemonics - see “man fdisk” for further information.

Note: fdisk will display if the partitioning you requested if not on any boarder.  That is why you use the “+” in (2) above.

It overcomes the user not selecting the required 2^x requirement.

3> Select those partitions you want to be bootable.

4> Select the “format type” you require for each partition.

And when you finished and happy with the partitioning table;

5> Save the table to disk with the “w” command, and you will be returned to the shell prompt as usual.

After all this, now your ready to install the particular file system formating on each partition as you require.

Hope this assits you.

Cheers.


#3

I would also consider writing zeros to the drive, just to make sure that there is no resident partitioning that would continue to cause the drive to be mis-aligned.


#4

Thanks. Yes, finally i made it with fdisk AND wrote zeroes to the drive.

Dispositivo Boot Start End Blocks Id System
/dev/sdb1 2048 2930272064 1465135008+ 83 Linux

 Everything was ok for a week: i use it inside an usb enclosure and i was able to read-write at 20 mbytes/sec. But that worked only for a week, because slowly the disk’s performance decreased to reach the average read-write speed of 3,5 mbytes/sec.

I don’t know what else could i do with that drive. it simply makes me crazy.


#5

PLEASE HELP.

Today the speed changed once more to 600 kb/s.

I have to backup 213 gbytes from that hdd.

i don’t know why. i don’t know why. this is not an alignment issue. no more an alignment issue.

Disco /dev/sdb: 1500.3 GB, 1500301910016 byte
255 testine, 63 settori/tracce, 182401 cilindri, totale 2930277168 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x0004faca

Dispositivo Boot Start End Blocks Id System
/dev/sdb1 2048 2930272064 1465135008+ 83 Linux

PLEASE HELP ME.

This is the output of  e2fsck checking /dev/sdb, not sdb1

:~$ sudo e2fsck -n /dev/sdb
e2fsck 1.41.11 (14-Mar-2010)
e2fsck: Superblock invalid, trying backup blocks...
e2fsck: Bad magic number in super-block durante l'apertura di /dev/sdb

Il superblocco è illeggibile, o non descrive un corretto filesystem ext2
Se il device è valido e contiene realmente un filesystem ext2
(e non swap, ufs o altro), allora il superblocco è corrotto, e si potrebbe
provare ad eseguire e2fsck con un superblocco alternativo:
    e2fsck -b 8193 <device>

#6

If I google translated the information correctly, it’s possible that the drive wasn’t aligned properly, or got corrupted in the process.  Just for you to know, in order to align the drive correctly, you must have the latest Linux kernel, or you have to know how to do it manually. 

Manually:

  1. Write zeros to clear out the MBR.
  2. Start fdisk, and set it to “u” for manual partition.
  3. Start the partition alignment on sector 2048.

Hopefully, that helps.