WD Access Won't Install

I just got a new laptop and am trying to install WD Access on it. It installed and worked perfectly fine on the previous laptop, but on this one, it won’t install. I download the WD Access zip file, unzip it, and go through the installation. It seems to go through the installation process fine, but the WD Access program is nowhere to be found. It’s not in the program list, task manager, nowhere.

Has anyone had this issue before and is there a fix to this?

@asinghal31 Have you looked at the following?

I should add that I’m on Windows 10.

Was this ever resolved? I am having exactly the same problem on a new Windows 10 machine (previous machine was also Windows 10). It goes through the installation process (as per the “How to install WD Access” page) but at the last screen instead of two buttons for “upload files” and “do this later,” it only shows “do this later.” When I click on that it closes but WD Access is nowhere to be found - not in the task bar, start menu apps, or apps in Windows settings.

I’m having the same problem when installing in Windows 10. The last screen has just the “do this later” button. When checking in the windows software folder, there is no WD Access installed… I’ve gone through lots of threads here on WD Community, but cant seem to find a solution.

same here, laptop hp, win 10, will not show this 2nd button, and would not installed

on my pc it works, not on laptop :frowning:

Me pasa igual que a los demás usuarios. Parece instalarse correctamente, pero al final no hay nada instalado.
Hace poco me paso con otro ordenador y la única forma que encontré fue cambiando la versión del sistema operativo (w10 pro a w10 home)

I also have exactly the same problem: WD Access (V1.4.5949.29996) worked perfectly on old PC. Now have a new one, downloaded latest version (1.5.6698), it goes through the installation process but one of the buttons is missing on the final dialog.

It then doesn’t come up anywhere as an available app, in the notifications area, etc.

I have tried downloading and installing it several times each with exactly the same result.

WD Sync & WD Quick View installed fine and work as expected.

This seems to be a very common problem. Hello WD is there a fix or response? It has been 9 months since it was first reported.

It is absolutely ridiculous that nobody from WD has been able to solve this issue. I continue to have this issue on most of my laptops. Would be nice if people would at least try to provide customer service.

Totally agree.
I am still waiting as well… the WD Access software needs to be checked by the developers.

I know it has been almost 2 years since someone last posted this issue, but I found a solution to it just today and I thought to share.
If your mycloud device is connected to your home router, then it means it has been given an IP address like all your other devices. what I did was just to type the IP address in the path section (its to the left of the search bar) of my windows file explorer and it showed. let me explain. I have another computer that is able to install wdaccess but then I noticed when I access my wdmycloud device on that computer, it shows an IP address at the top of the file explorer starting with 2 backslash (\). so I simply typed it in the file explorer of my new computer starting with the two \ and it worked. note my new computer was also connected to the same internet as my wdmycloud.
I know the IP assigned to your wdmycloud could be different from mine, so here is what you do to find your IP assigned.
go to the windows search and type cmd to open command prompt, type " arp -a " then enter.
if no other devices are connected to your internet, your wdmycloud should be the second on the list under the internet address section (if it’s not, try all the ones your see). Enter that in the file explorer path section and it should lead you to your files on your wdmycloud device. hope this makes sense and I hope i was of help. let me know.