WD access software incompatible with mac

Ok guys, anyone have any ideas?

I’ve just spent HOURS trying to set up my new WD MyCloud 6TB Generation 2, and it still won’t work properly.

I can access the drive myself via the “Shared” folder sometimes, although that doesn’t always work. I can access if I “connect to server” also.

But, the software (wd access for mac) doesn’t work?!? I don’t want to log in to the web dashboard every time I want to check the drive.

Also I want to daisy chain another 6TB my book connecting it via a firewire, so If I try to do that I need to make sure I can change the RAID. Meaning that instead of 3TB of data, I’ll get 6TB of data in total (with RAID). I’m not sure if I can do this but I thought I’d give it a go. I’m a photographer on the road and really need remote storage and backups for clients.

Here is a screen shot I found and my iMac seems to have decided it’s incompatible.

I think I might give up altogether, send it back to the store and get a Synology instead if I can’t figure this out.

Any ideas?


What version of Mac are you using?

Are you using the latest version of the software from the WD support site?

I’m iMac.
OS X El Capitan

WD Access:
Release Date: 6/21/2016

I’ve also tried updating the firmware.

So I’ll all up-to-date.

I’ve loaded WD MY Cloud which works, but that doesn’t check the drive, that just uploads content. The main “WD Access” doesn’t work still. I’ve also tried WD Drive Utilities, which doesn’t do anything.

So basically, Western Digital Software doesn’t work.

I’m going to give it one more try to see if I can figure it out, if anyone has any ideas that would be really helpful :slight_smile: