WD 74gb raptor not detected by bios or windows

I had two WD740Gb raptors in my Win 7 PC my wife uses as well as 2 other Seagate data drives. These raptors were in raid 0 and about 1 mth ago failed. I found out via tests that only 1 of the drives failed and RMA’d that drive 4 days before expiry. Thinking the RMA will take ages, It has btw , I installed the remaining 74Gb drive as a bootable C drive and used it for 2 weeks. I then uninstalled it and packed it in an antistatic bag away till the new drive came. I am using a new WD blue  drive as Cdrive till then.

I tried to format and clean up the data on the 74Gb drive but it now is not detected by the bios in the PC it was working in nor the PC I tested it in when I was checking which drive was faulty. It really sounds as if the drive is not spinning up it stays cool and quiet.

Board is a Asus P5B-e and the drive has been in this PC for 5 years as a raid and 2 weeks as a single bootable drive so has it failed?

I tried 3 sata cables, 2 sata power and 1 legacy power cables as well as 3 sata ports and 3 power supply molex connectors.in 1 PC and similiar combinations in the other. If I had the RMA I could confirm the issue better but it is somewhere in china at this time.

I disconnected the WD blue and tried the cables it was using. Upon reconnecting it the bios detected the WD blue drive immediately. It did not see the 74GB.

I have 8 days warranty left though in the former failure the drive was recognized and could be tested this 1 cannot be seen ever.

Any thoughts?

PS PC experience high and not solving this bugs me.  Redid teh testing many cable combinations and still no detection and nary a sound from the drive not a peep or any heat.


you have already confirmed it needs to be replaced

process an RMA online 

You can also contact tech support and they can do it for you.