WD 3TB My Book Live Problems

I guess I could have labeled this topic " In need of guidance",
I purchased my “My Book Live” in 2014 and it died on me a few days ago.
I bought the 3 TB version because I couldn’t afford the 4 TB version (I was in the middle of building my PC), I’m running a Crucial 128 GB ssd for my OS and a 4 TB Seagate ssd / hybrid as my secondary which happened to be a great deal cheaper than the My Book Live, but I’m thinking; self contained Network Access Storage could only be a good thing.
So you could imagine my utter disbelief when I opened my personal cloud to find a WD green DESKTOP Hard Drive inside.
Why oh why, would you put a desktop hard drive in a device such as this. If I wanted a desktop hard drive I would have bought one.
Fortunate for me most of my cloud (not all) was backed up to my 4TB secondary drive
So now I’m looking for a replacement drive.

  1. Would the cloud have issues seeing a larger hdd other than the one for which it was intended?
  2. Is the cloud interface on the board firmware or is it stored on the hdd?
  3. If it is stored on the drive, would replacing the hdd with a WD red make it plug n’ play?
  4. Could I use a different brand name hdd in the cloud?
  5. Recommended hdd spec for replacement drive?

Have a diskless 3TB MBL myself that I bought in 2013 and crashed two years later. I opened it up and saw a RED WD hdd which I used as sn external storage medium but my Vodka loving friend dropped it and did it in as well, so I “kind of discarded” my MBL afterwards. Then, I recently came across a thread that makes it possible to resuscitate MBL and there are two ways in which it can be done. I got myself a (normal) 3TB hard drive since I could not find a RED version; I am told that works as well, but I do not believe that it will be reliable over a long time used in an “always on” environment like a NAS. Nevertheless, I will keep you posted on my progress with rebuilding it.

I think you were scammed from wherever you bought it from

as i’m pretty sure all WD Network Products contain RED’s

My… WD My Cloud 2TB has a RED inside

and searching around the net all i can find is WD My Cloud Home’s with RED’s inside.

This is the device I have. I would have used the exact link I used to purchase it on Amazon, but to be honest I really didn’t read the EULA.


and the other two pics are what my cloud looks like at present…
This was used as a media server more than anything, If I had the slightest idea that there was a desktop hard drive in there I would have probably built my own server.
ndlelex, do you know if the data on the drive is encrypted? Because when I plugged the drive into my PC and used “DiskInternals Linux reader” it sees the drive and gives a fairly accurate reading for total,used and free space, but I can’t access anything. Even if i boot into Ubuntu it won’t mount.
I am thinking if I am going to use a WD hard drive my options are Purple, Red or Gold.

I wouldn’t say the files are encrypted because I used some file recovery software (something I pulled off the net; don’t remember the name) after having done a quick format to NTFS to retrieve at least some of the stuff I had in my crashed MBL hdd. The files showed but not as were (file names were coded but the extensions were the same, something like what you’d see trying to access music files in an iPod). You’d just have to rename what you retrieve to whatever file name it had. Before all that, I had tried to read it on Windows Explorer (which didn’t have the slightest chance of doing) before finally being able to mount it in Zorin OS. Don’t remember the file system it was on, but the disk was manageable there. Well, we are going back a good few years here so I may not remember all the specifics, plus I am a novice when it comes to these things.

Well I finally received my replacement Hard drive. I took a chance and purchased a factory refurbished 4TB Red Pro because to be honest I wasn’t positive that the problem was the HDD.

I used this guide [ [GUIDE] Debrick MyBookLive v2.0 ] a special thanks to “nfodiz” for taking the time to put it together.
Unfortunately I encountered an error " 31103 - Upgrade download failure. Please try your upgrade again."
Has anyone encountered and solved the error.
I just need to be sure that the firmware / image i used wasn’t tainted, giving someone access to my cloud and by extension the rest of my network.

Problem solved… I think
To solve the problem I had to do a manual update, from the web interface go to settings - system - updates and click “choose file”.
To get the latest firmware I went to https://support-en.wd.com and selected product support, then chose legacy products, then clicked on My Book and then clicked on My Book Live and scrolled down to current firmware and hit download.
Now when I click on check for update, I get “Your firmware is up to date.”
So now I am going to load and stress test the drive before I start putting important stuff on it.
Wish me luck.