WD 3tb drive enclosure, usb interface dead

Hello folks, i’ve just had a WD 3tb drive enclosure apparently die, no reaction to connections. May have had some magic smoke escape. Tried on multiple computers etc. The usb interface appears dead.

Hoping that the drive was salveageable, I stripped the shell, found a circuit board screwed to the top, pulled it off and found it was a normal (?) SATA drive, a WD red to be precise.

Pushed the drive into a drive drawer and it came up. No drive letter though so I used Windows’s partition manager to have a look at it and it is there, quite alive with a "GPT Protective Partition on it and 768Meg unallocated???

Can’t delete it, can’t reformat it, can’t do anything inside windows with it.

Now, I am running a windows 10 pro x64 UEFI system should I not be able to see it and use it?

I plugged it into a spare external USB dock that I had lying around and I can access it as before, data is all there. Still can’t format, delete, nothing.

Is there any way I can reformat it to be useable “Inside” my UEFI system?

Maybe you can use MiniTool Partition Wizard Free edition?

https://www.partitionwizard.com/free-partition-manager.html

Tried that and others. Nothing worked but I know why now I think. I could only format and use it while it was pushed into the external drive dock.

For some reason Windows 10 won’t do anything with it even in UEFI mode which is supposed to handle GPT disks and create them.

I’ve been reading somewhere that the 3tb (and up) have some sort of encryption built right into their firmware so nothing I can do will help.

There is apparently a complicated linux hack to do something about this but I forget where. (And I doubt I could follow it)