WD 3TB causes BSOD during boot


I recently installed a new WD30EZRX disk to my asus rampage formula based win7 x64 pc. Now at first, the machine only recognized 800GB of the disk so I updated the Intel Rapid Storage drivers, rebooted and initialized the full 3TB of the disk. I spent the next 2 days using the disk, without reboot and everything worked great.

Then on my first reboot  went into BSOD. Only by deactivating the disk can I get windows to boot.

Now, windows debug thinks the bsod might be related to nvlddmkm.sys, but thats a nvidia driver (if I remember correctly), and I dont really see how that would be affected by the 3TB drive. (Besides, all my nvidia drivers are updated).

I’m curious if windows will recognize the disk if I hotplug it after windows has booted. I have a feeling it might work, but thats for later this evening. In the meantime… any suggestions?

You could try Running  DLG or  updating  your BIOS.

Tried updating drivers and bios, but I still havent found a solution

So, the problem still remains. However, I have found a workaround:
It seems the problem is related to drive-spinup/windows startup sequence. If I pause the bootup, wait until I hear the WD spin up, then resume - then windows starts without problems.