WD 2TB Elements USB 3 - Unplugged without eject

Dear all,

i have searched this forum and other places about the issue i am having with this WD product as described in the title. I wrongfully unplugged the hard disk without switching of the WD TV Live it was connected to. 

At the beginning it was not being detected but then suddenly it was detected and all was normal, moving files to it and streaming. I kept my PC on in order to keep it connected but suddenly while the PC is on it disappeard. The light is on (not blinking) but it shows nowhere in the computer (i.e. not in the BIOS, diskmanager, device manager, explorer,…), i also tried changing the cable and connecting to different computers.

I appreciate if someone can point out what could be done to restore the hard disk to normal operation, although unplugging the hard disk without eject is a big mistake but i dont expect a 2 TB drive to be that fragile!


Hi Adham_1980, welcome to the WD Community. Unfortunately you have tried all of the relevant troubleshooting steps. The hard drive appears faulty and needs to be replaced. Check the link below for more information. 

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty