WD 2Go Pro & Video Files

Is any one having problems playing *.mp4 & *.mov video files on an iPad3 using the WD 2Go Pro app?

I get an Error message “Unable to play this media file”. I have a 4MBS upload speed on my ISP so caching shouldn’t be the problem. Even after I Clip (download) the file locally, it still will not play. If the file is less that 4GB in size it will play, >4GB it will not play.

The same exact file WILLplay fine if I stream through iTunes or if I put it locally on the iPad.

Can WD provide some help.

Have you tried to copy the file to the iPad and play in from there?

yes, i already said this on my original post - fille will play

Here’s the reply I got from the WD support:

"WD2Go can only access files up to 2GB. I recommend that you re-encode your media to be smaller than 2GB if you plan to access it remotely or through your iPad."

Are you joking, re-encode all my files to < 2GB!!!

Why isn’t this detail mentioned anywhere on the product specs for the My Book Live Duo or the WD2Go Pro App? You should make this limitation very obvious to potential buyers. The 2GB limitation make this product very limited and if I have known that, I probably would not have made this purchase.

VERY DISAPPOINTING !!!

I think the limit is 4GB, not 2. I have a number of 3+ GB files that work fine.

More important for me is that most of my video viles are m2ts and won’t play. I tried an app last night called Media Connect and it appeared to stream and play other files faultlessly. I may stump up for the full featured app.

Whoa. Hold on. M2TS files arent supported by Apple, are they?