Wd 2go network connection failure (907)

Wd 2go can not connect to my Wd my book live 2 TB .

I get the error wd 2go network connection failure (907)

I tried to do a find in my local network when connected via WIFI it does find mybooklive it ask me for the passsword

and also show me the name on the device it just fails when i try to open it.

did the same trying to add it with a code. find the device add it to the list I just can not open it.

I was thinking of just doing a  complete reformat of the drive but I thought lets ask the experts first.

Anything that can be done?  the drive works normal from my PC to it and my other connected devices it…

Only issue is with WD 2 go.
 the drive has the latest WD firmare



I did a complete reformat and still no luck,

The drive works fine from within my network so its must be a bug on the latest WD 2go android app and a EVO 3D phone.

Has anyone experience the same?

I’m having the same issue. same phone.and same error. I try to connect though my mobile internet. It’s worked before but now… Nothing
Someone with information needs to reply please

I had the same issue with my Droid 3 phone on Verizon’s network.  My home internet connection is through Comcast using a Motorola Surfoard router. I dropped the firewall entirely and didn’t see any change.  I then stopped my port forwarding (I’m running a web server on one of my computers) and the error changed from 907 to 905.  I’m not sure if that’s an improvement or not, but at least it’s a change.