WD 2go emailing wrong links

I have a My Book Live (02.11.12-060) and a new iPhone version of WD 2go (2.0.1).

I tried to Email link to file/folder (several times) from WD 2go to myself but a generated link is always wrong and file cannot be downloaded! Browser says “Safari cant open the page”.

Files/folders I was sending was from “/Public/Software/User Manuals/…”.

Generated links were like " http://mybooklive.device123456.wd2go.com:0/api/1.0/rest/file_contents/…".

What I found interesting was when I delete port from a link (like bellow) the file download will suddenly start but then it is redirected to original link.

" http://mybooklive.device123456.wd2go.com/api/1.0/rest/file_contents/…"

Try using another web browser.

If you’re trying to access the my book live’s manual link through wd2go, that won’t work.  you need to download the manual on to the my book live and then you might be able to access the file.  however, does wd2go allow you to view pdfs?  

Alucardx23: So according to you when it does not work in Safari on Mac and in Safari on iPhone it is OK? I seriously doubt it is a problem of the browser. It is a bug in WD Software.

Wayne: It’s totally about something else.

Well, the links are “correct.”  but for some reason, being appended with the :0 tells Safari to access TCP port 0 to access the WebDAV server.

That is, obviously, incorrect.

But mine (iPad running 2.0.1) isn’t doing that, so I wouldn’t know why yours is…

Only two suggestions:

  De-authorize all of your devices / then disable Mobile Access / Reboot your MBL / then re-do the authorization  & pairing.

If that doesn’t work, I guess maybe a factory restore is in order…

Tony, thanks for a reply. Unfortunately I did a Full Factory Restore after firmware update and WD 2go app was clean installed on iPhone, so that a brand new Mobile Access was created.