WD 1To not recognised anymore - Need help


I purchased an external disk WD 1To USB 3 ; it went fine so far but since a few days ago, when I connect it to y PC it is not recognised anymore.

I have tried a couple of workaround :

  • I have tried the disk on another PC => same results

  • I have changed the cable => same results

  • I have seen several posts on internet proposing to check the “manage computer” option but when I select the “manage disk” , I am being asked if I want to initialise the disk  . I have not continued yet this step as I don’t know the consequence if I type OK. I have attached the screenshop below ; it is in french, but I think this should be undertsandable for non french.

Questions :

  • Can anyone tell me what the risks are to “initialise” the disk ? Do I risk to lose the files currently stored on the disk ?

  • Can anyone suggest me anyther workaround to solve my problem ?

Thanks in advance for your help,

Hi, if you need to recover your files, use a data recovery program like testdisk or recuva and then initialize it.