WD 1TB My Passport Drive EXTREMELY Slow!

#26

Same problem here. New hard drive on laptop so it’s not that. Very slow to recognize the drive. WD drive (hardware) tested fine. Uninstalled software and reinstalled. Just want to get my data off of it.

#27

I have a same problem too:(

#28

Good morning. I own a data recovery company in Maryland and I fix these all of the time.
If the drive spins and continues to spin without clicking you have what is called a slow responding problem. The good news is that the data can be retrieved but you need a specialized tool like a PC3000 (which costs multiple thousands of dollars). Any good data recovery company should be able to get the data for you.

#29

I have 2 WD Drive, both were having the same issue. Suddenly very slow to detect,

#30

Hi everyone i had the same problem and i was searching the solution for it and then tried to format the hard drive with exFat format and after it finished
i copied a movie to the drive and it works it goes up to 25 mbps you all should give it a try hope it solve your problem also

#31

I have a simular problem, except its 2018 and clearly Western Digital hasn’t done anything to resolve this matter.

I purchased a WD My Book 4tb external HD and spent 5 days copying files to it from my internal HD’s and when I had the drive nearly filled up it started acting like it was dying, which was of great concern as I was barely pushing the HD to its limit. I should point out that I do not have the click of death, although everything else indicates the drive is nearing death as it is a piece of ■■■■.

Now for the past 3 days I have been moving the files from the drive and getting ridiculous transfer rates. I tried everything to resolve the matter, reinstalled everything, checked everything, searched for solutions, contacted tech support, etc, with no success.

I’d venture to say that WD designed the HD’s to perform as they do and built them to be very frail.

#32

If any find a solution i will be very happy.
I am surprise no one realize the problem appear when the hdd have data over 50% of the total capacity. the speed is this if hdd is under 50% those drivers are amzing, if you pas 50% speed go in 1/2, close to 80% the transfer speed is about 2Mb. 90% forget about it.
that firmware think is just to keep you busy and have nothing to do with.

Will be nice if any from WD can replay to this problem.

#33

Same problem here.
Just, I found a turn around to take back my files :slight_smile:

  • connect the drive and launch robocopy immediately
  • it starts fast and slow down after about 1mn, then CTRL-C and properly disconnect and reconnect
  • it copy 300 to 900 Mb each time at reasonable speed
    A little bit tricky, but far faster than just waiting.
    Can anybody confirm ?
#34

Hi all
had the same issue. chkdsk /r took way too long for me (probably days), so i never completed it. I updated the firmware, ran the WD diagnositics software (short version only because the extensive test would take days).
Tried all of the stuff i found on the web, including switching the policy to “better performance”, nothing helped.

HOWEVER i have good news:
here is how i fixed the issue: I started the windows device manager and clicked on “properties” of my WD external HD. Then i went to the driver settings and UNINSTALLED the device. Unplugged it, rebooted the PC and plugged the WD external hard drive back into the USB 3 port. Now i have transfer rates of up to 100Mb/S

I assume some of you really might have hardware problems, however, for me, it was a simple driver issue…

btw: Win 10

#35

Hi all,

I know the topic may be outdated, since it’s 2018 already, but I still do have WD My Passwport Ultra 2Tb
and I SOLVED THE PROBLEM of slow working.

I read all the thread and noticed a post by Raymund_Arthur, he suggested to update the firmware.
And it really helped!

So go to their official website > downloads https://support.wdc.com/downloads.aspx?lang=en
you need “WD Universal Firmware Updater for Windows” or “… for Mac” if you’re on Mac.
Download it, install it, restart your PC - it will update your external drive to the latest version.

Today (2018, Aug 5), it updated from 1.0.6 to 1.2.2 and now on Windows 8.1 it works PERFECTLY!

Hope it helps!

#36

I too had this issue with my daughters external WD Passport Ultra on which she had her thesis and no backups.I tried updating the firmware with no change - the drive still took 4-5 minutes to be recognized and never actually could be opened to see files (even after an hour or so).

I took the drive to local drive repair place with a clean room and they barely examined it and then quoted a recovery cost of $2275 (including parts). That was just ridiculous but if nothign else worked we would have had to pay the price.

So, we took the drive home and I started looking at it. I had a partition utility called AOMEI (standard edition) that could see the drive name and the free/used space. That was encouraging since data was coming off the drive. I ran an option called Check Partition which runs chkdsk.exe and it started finding and correcting file and disk errors and after about 40 minutes it had finished. When I rebooted, I could now see the drive properly and all the files were back and performance was restored. You can probably do the same thing by just running chkdsk.exe on your own.

I hope that helps someone else with a similar issue. It saved me days of waiting and a lot of money.

#37

Having same issue. Hard drive responds much lately. Transfer rate is between 0 kb/s to 700kb/s. It is taking 4 hours to transfer even 800 mb of data

#38

My oem 10 year old 500gb drive haw same problem its now for storing data, when temperature is high it clicks and dont want to boot. When it is recognized it starts to read only 500KB Can firmware update can fix this?

#39

December 2018. So, 5 years and counting and still no resolution? Not one WD support technician thought to address the issue? Are we in the wrong thread? Not one suggestion? Really?

Surely, WD has been made aware of the issue since 2013? And yet, despite knowing the devices are prone to such costly complications, they continue to produce and sell such defective products without any notice, explanation or resolution?

I am just amazed there has not been one response from WD this whole time.

Can somebody say class action?

If anyone can provide any other suggestions besides the firmware update (not working for my passport 1TB). I am all ears.

1 Like
#40

same here d2d
like ur videos btw

#41

I bought a 1tb My Passport (black) from Walmart about 18 months ago. The drive worked well for 3 days. Ever since then it has been ultra slow. I had a lot of important data on the drive but it didnt do me any good because most of the time I couldnt access it anyway. So I finally got fed up today, and I deleted everything. It takes an hour to delete even a zero byte empty folder. So the only way to actually delete the data was to try and reformat the drive. I deleted the partitions first, then I did a quick format using exFAT. It took forever to do all of this. I was hoping it would solve my problem, but it didnt. I am trying to run a scan on it now. I am scanning for bad sectors and whatnot. But here is the thing… I bought this drive, and paid for the warranty. I registered the drive too… Guess what? No one will help me. I cant even get a replacement drive. Hell, I cant even get an answer as to why this piece of ■■■■ has been garbage since day one. I never once dropped it, I never over-heated it, I have never done anything to it that could cause this ■■■■. It is just a garbage drive and I want a ■■■■■■■ new one, or better yet how about giving me my money back.

#42

Every one is having same problem so do I but does anyone got any solution…
my hard disk gives 50kb/sec speed now… don’t know what to do…

#43

I had a 4 TB WD My Passport Ultra. The P/N shows WDBYFT0040BBK-0A; S/N shows WX41D5873FY4; product of Malaysia. The extreme data transfer problem issues directed me here. I’ve tried the “Stupid’s Solution” of “Better Performance” in the Policies.

Naturally that didn’t work. Then I’d downloaded the Universal Windows Firmware Updater. I’ve noticed that the Updater itself is of 2017. However, it showed that the firmware is up to date.

This problem was reported on Dec. 12, 2013. Since then lots of other people had asked for the solution. Today is Apr. 17, 2019. It’s nearing 6 years, but nobody from Western Digital cared to answer even once. Actually, they didn’t even acknowledged this problem!

I have Transcend 3 TB, also SanDisk. They don’t have this problem.

I’ve tested my WD 4 TB in Windows 10 Pro x64, Windows 8.1 Enterprise x64, and Windows 7 x86. Everything is okay in those PC and laptops. So the problem is with the WD 4 TB. Actually its a hardware issue which WD can’t fix!

Sadly I had to say that WD can’t make a USB hard disk!

#44

I can’t believe I wasted 30 mins reading this discussion and no one had a solution. What’s the point of these forums if WD or no one gets involved? Ridiculous.

#45

I have same issue with My Passport 1T