WD 160 GB External Drive Not being Recognized under Windows 8.1

All of a sudden, when I plug my WD 160GB external drive into my computer, the computer will not recognize it.   It does beep like it found it, but then immediately beeps like it is being unplugged.   This cycle continues over and over and over.  I rebooted and shut down the computer and unplugged everything and then tried it again.  Same result.  It is like it finds it, but then turns it off immediately.  It does not show up under Disk Management or Device Manager.   If I left it plugged in, the beeping noice from Windows would continue forever without the drive showing up.  The drive does have data on it that is a backup from a Sony PS-3.   I am just trying to format the drive again to FAT32 so I can back up my PS3 before upgrading the hard drive.   Thank you for any help.  Brad


Please be aware that if you format the drive it will erase all the information on the unit.

Have you tried using the WD DLG tool to see if the drive shows there? You will be able to test the unit and in case that shows there, you might be able to format the drive.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

1 Like

Thank you.  I downloaded the utility and ran it.   The problem is, the second I plug the drive in, I get the “recognizing” beep from Windows again like it finds the drive, but then I get the beep that sounds like I am unplugging it.

I did plug the drive into an older netbook I have that runs Windows 8.1 and it found the drive right away and I was able to access the drive with no problem at all.

Any ideas why my desktop will not recognize the drive?  The USB ports are good as I tested them out.

Thank you.   Brad