WD 1 TB Hard Drive not detected on Windows 7

HI,

I have two HDs of Western Digital, 1TB and 2TB. Please go through below points to have quick view about my problem:

  • 2TB HD is working fine. 1 TB is detected and shown in My Conputer, but can’t open it. If I right click, explorer hangs/not responding. 

  • Sometimes 1 TB HD is not detected.

  • Luckily, I have same connectors and both original for 1tb n 2 tb. So, I tried to connect 1tb with 2tb cable, but same result.

  •  I tried Disk Management : “trying to get information” [15 minutes taken, still running]

  • I found few more options in Windows 7.  “Windows Defender”. Now I am scanning my drive but no progress yet. It shows “Retrieving data from your system to prepare for your scan”… but its already been an hour and scanning has not even started.

  • Last time I had same kind of issue [not so serious like now] I used my office laptop with Wndows XP. The drive was so happy as if it met someone beloved. But this time, I dont have any system with Windows XP.

Formatting HD is cruel for me. My office documents are stored in it. And yeah… Windows 7 is not even giving me a chance to format the disk … 

I wonder what do WesternDigital Softwares do? There is no troubleshooting options

Hello, you can try running a test with DLG to verify if the hard drive has a hardware or data corruption problem. 

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

You can also check if the hard drive is recognized on the disk management window. 

How to access Disk Management in Windows 7, Vista, XP or 2000 to manage your hard drives

Hi,

For latest update, somehow I managed to access 1TB drive. Earlier this drives was ‘NTFS’ file system, now its changed to RAW and shows 0 bytes used. Does this mean I’ve lost all the data? If so, is there any chance to have data recovery.

Attached screenshot for your reference.  Appreciate your help here. WD.png

Raw means that the drive is corrupt. If you are thinking about profesional recovery don’t do anything. Something like EaseUS Data Recovery it’s try and buy http://www.easeus.com/datarecoverywizard/recover-raw-drive.htm might work. A last ditch thing to try is running the command prompt to convert FAT32 to NTFS. That sometimes works. This Link has the prompt http://support.microsoft.com/kb/214579 .

Joe