WD 1 TB external drive on Mac OS Lion not functioning

I updated my iMac to Lion and all seemed well with my 1 TB WD external drive (about 2 years old). Yesterday I tried to boot the computer and it hung until I unplugged the WD drive. I tried to add the WD drive after the iMac was running but it does not show up on the screen or in disk utility. I tried with a Mac book and it will not show there either. I need the info on the drive. How do I get it to work as it did before?

1 Like

I have the same problem as you. my wd 320 Mb is working well, however 1TB disconnects on its own after 5 min. The firmware is updated but the problem exists.

Same prob.

1TB Drive alerted that it was disconnected incorrectly.

Hasn’t shown up since.

I can’t access Important data.

Please advise.

Same problems here - can’t get this drive to work reliably with Lion.  Spent a very frustrating week with this hard drive - in frustration finally bought a smaller (500 GB) Seagate drive for performing Lion backups.

Nice to see proactive response from WD employees to these issues!  Returning this drive ASAP.