WD 1.5tb Elements not working

Hello, I have a WD 1.5tb Elements that just doesn’t work after plugging it in on my laptop … there’s no sound coming from the drive and the light is always on ( not blinking ) my laptop recognize the hardware but doesn’t seem to know what kind it is ( the driver or firmware … usually it detects it automatically ) … I tried it on a windows 7, Vista and XP OS’s but still they can’t detect it … I have until December 2012 for the warranty but I like to ask if what will happen to my hard drive and to the files … is it still available for repairing? Hope anyone can help …

Hi, you can try to search if it’s recognized on the disk management window, check the link below for the steps.


Note : To see bigger try to right click and choose VIEW IMAGE

I tried the steps but it still didn’t show my External drive on my laptop …

This is what my computer detects … ( even if I pull the USB plug from the laptop or from the external drive the light doesn’t blink or go off, it just stay on steadily … only when I pull the power off )