WD 0730 Formatting Problems

Alright, I have access to an HP Pavilon dv5 laptop with Windows Vista (64 bit). I can also get onto a Windows 7 desktop (not sure of any brand information).

I was once able to use my WD My Passport 0730 external hard drive on the HP laptop. I had to bring in the laptop to fix the screen and I switched the external hard drive to the Windows 7 desktop and the computer could not access the information. Long story short, the laptop came back and I could not access anything on the external hard drive with the laptop either. It does not show up under My Computer and just freezes the computer whenever I try to access My Computer witht the drive plugged in. It does appear under Disk Management.

One attempt to run a registry editor program let me use the external hard drive for a brief moment. I tried to move a file onto the hard drive after I could open it, it froze, and now it doesn’t work again.

Most recently, I gave up on saving it and want to reformat it so I can use it again. However, after going into disk management on the laptop and desktop, neither can reformat it. I get a variety of error messages basically saying it can’t format the drive (Vista and 7 give different errors). Surpringsly, one attempt actually sort of did something. It formatted the drive to a RAW format. Any attempt to format it to a different setting (I think it’s NTFS) failed.

I tried running the WD Data LifeGuard Diagnostics. The passport fails the SMART Status. RAW Read Error Rate and Re-allocated Sector Count are the only red X’s. I can not run a Quick Test, nor can I Write Zero’s anywhere.

Any help is greatly appreciated.


Sounds like a bad hard drive, if you can replace it.