Watching 1080P MKV paused...stuttered...a few times

I have the new WD Live TV unit…the picture quality is superb. Last night I streamed a 1080P MKV rip…from my imac using

Twonky media server…it played flawlessly until a bout a half hour into the movie…then all of a sudden it stuttered and literally stopped like it was frozen. Then I paused the unit and hit play…and at first the sound track was off for about a half minute…then it seems to start playing normally again…dont know what caused if or if there is a firmware update relating to the issue of 1080P playback…anyone else experience this problem??

Just had this problem myself, and solved it.

This was happening with every video I tried, including those I’d previously played okay.  The videos were played from an attached USB HDD.

How did I solve it?

Go to Network Share Server and turn it to OFF.

If this works for you, please let us know.

Steve W

Pecker wrote:

If this works for you, please let us know.


Steve W

Who is “us”?

‘Us’ the forums.

Steve W

I agree - this solution worked.

With larger mkv’s, the video would stutter, the audio would cut out, and things would come to a standstill after several minutes.  This is with local storage (a 250GB external hard drive).  I am using the latest firmware to date (1.04.12).

Turning off network share server did the trick.  All mkv’s run smoothly during the length of the file.  Hope the next firmware update fixes the issue, so that I can turn network share server back on.

Good news that it’s fixed it.

Steve W

There could be another solution to “bypass” this problem. You could try to connect your USB hard drive to the front USB port instead of the one on the backside. That did the trick for me.

It would be great to know if it also works for someone else.


I’ll give it a go.

Steve W

Same issue here.  Hmm… I’ll have to see if some of these suggestions help.

I ended up pushing the button on the bottom of the unit and things are working fine now.  I haven’t attempt to connect to the storage over the network yet, so we will have to see if that causes  the issue or not.  I’ll update soon!  Thanks

Clearing the network logons seemed to have stopped the stuttering.  Weird!  Still runnin the older firmware…

started happening to me as well with the new firmware. tried turning off the network share and nothing changed.
hit the reset button on the bottom of the box and it now works perfectly. weird…

Same thing here with 1080p mkv files. They play just fine for few minutes, then start stuttering and lose sound.  A quick rewind then play fixes things for another minute, but then this stuttering starts again. No matter if I play them from local storage or via wifi. (I have to mention these are the same files and the same external USB drive that worked perfectly with my old WD TV gen1.) This is really annoying! Also, last night all 1080p files were working again, and I really don’t know what I did to make them work :) I didn’t even know there’s some button in the bottom of WDTV, but I guess I’ll try it next time this issue appears :slight_smile: For I bet it will appear again :) Hope they fix it!

I’m having this issue as well, tried using Servio.  Still not working.  Anyone have any other ways?

I ended up clearing the network share logins.  And then it works.  I have no idea why this would allow it to work correctly but it does every time.  This is the first Gen WD TV Live, connecting to a 2nd Gen WD TV Live that has a 2.5 TB WD drive attached.