Was MyBookLive hacked?


I have been using a MyBookLive for several monthes from now and it worked perfectly. However, soon after I configured an external acccess in order to be able to browse my photo from my mobile phone it suddenly stopped working. I wasn’t able to communicate with it anymore. I suspected at first a problem with my BPL plugs (I had many problems with them) so I was not really worried until I tried to fix the issue. I also suspected an IP conflict adresse since I had some weird messages on my PC saying that the name of my network drive (mapped to my MBLive) was already in use. 

Here’s what I have done so far : I connected my MBLive directly through ethernet cable to my ADSL box in order to remove the BPL from the equation but it didn’t fix the problem. 

Then I suspected an hardware problem so I checked my cables (tried differents ethernet cables and even swapped the power outlet with the on of my other MyBook (a older world edition, whith works perfectly) . I also tried the different ethernet outlet from the ADSL box and to lake sure I disconnected my other MBLWorld edition but Nothing worked. 

Then I check the communication status on the backface leds; The link led is green so the device has a gigabit connection up and running. the activity led is blinkink so there is some traffic. Finally, and more importantly, the front led is blinking green, which means - according to the user manual - that the drive is currently reading or writing stuff ! **bleep** ? 

From my PC, each time I click on the network drive icon i get a message saying that the name already exist on the network.  So I distonnected the other MBworldedition from the network, removed all BPL plugs and restarted every thing. Same results. Then - suspecting an issue from the PC side, I decided to disconnect network drive with the intention to remap the drive. That’s the point where things got even worse for I was not able to remap the drive. The windows network discovery feature (I  using seven - I know, I know) does not see the MBLive. 

Lastly, I tried the very first reinstallation steps using the MBLive software but as I feared it didn’t detect the drive (the user manual states clearly that you have to wait for a stable green led in front of the device which never happens)

So to sum up things, my MBLive seems to do stuff but is not detected by my PC and I cannot communicate with it… What can I do next? doest it look an hardware issue to you ? or was my drive hacked and is now working on its own as a bot for some hacker ? (I know this sounds a bit paranoid  :)  )  

Any help and suggestions will be greatly appreciated !

Hi Frederic.C, it doesn’t sound like you were hacked. The “name already exist on the network” message usually appears when you have other network devices on the same network with the same name. If you have recently changed the name of the My Book or other device on your network it might be the cause of the problem. You can try pressing the reset button on the back of the My Book for 4 second and that will restore the configuration back to default without deleting any of your files. You should also be able to access the My Book by connecting it directly to the PC.