Was my WD Blue Hard Drive defective? won't run on new computer, freezes old computer as well

Hello everyone,

I’ve built a new system with a WD Blue 1 TB Desktop Hard Drive (WD10EZEX ) , after I built the system  andI started installing Windows 7 I noticed something wrong from the beginning, everything was slow, on the Windows installation " copying files" was stuck at 0% for a long time so I turned off the computer and proceeded to reinstall again, after that on the partition selection I got “Error 0x80070057 failed to format partition” and I couldn’t reformat and install. Turned off, turn on again, then it was stuck at " setup is starting", then I turned it off again. Then went to bed.

Then today I proceeded to do everything again and instead I got this message:

“BOOTMGR is missing press ctrl+alt+delete to restart” This was without the Windows 7 disc in the drive,

I proceeded to reinstall windows again and still stuck, I changed sata cable, same problem. So then I decided to take the hard drive and add it to my old computer to see if I could re-format it, attached sata cable, power, then turn on computer and now this old computer is stuck at the windows logo after boot!!! then after I disconnected the Hard drive everything worked again, so I’m sure there’s something wrong with the hard drive that’s locking something, how can I diagnose it if I can’t access it??

Any suggestions? maybe the HDD was DOA since I got it?

Thanks for all your help and suggestions.

Hi well you need to test the drive. You can use WD data lifeguard tools to do so. You can get it here run the windows test if you can.  http://support.wdc.com/product/download.asp?groupid=606&lang=en

That’s the problem, I can’t access the drive in my new computer or the old one…

Hi does bios see the drive if so you can use the dos version of data lifeguard to test it. You would make a bootable USB stick and put the dos version on it. If bios can’t see the drive on either PC you can RMA it or just return it to point of purchase and exchange it. There is not much more you can do like you tried it on 2 PC’s and they both have the same problem so 99% it has to be the drive.

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.

I was reading what you were saying and the smallest os you can boot off a USB stick is Linux which I got to boot off of a 4 gigabit and work the minumen amount you need to run windows is around 30 gigs i have tried to do on a 20 gig mstata drive with no luck 

Hi iamthecpu I guess you never made a dos boot disk so actually dos is the smallest os you can boot from a USB stick. But with my luck there is likely something smaller than dos hehe . Booting from a USB stick with dos just lets you run dos based test programs. A search on goolge for “create dos bootable usb” will give you the information on how to.

Can I put the Data Lifeguard Diagnostic for DOS on a USB drive?

Here says:


  1. Extract the dlgdiag5.exe file and copy to a DOS bootable diskette.

How can I do this if I don’t have a diskette drive? can I put it in the same USB stick with the bootable CD and DOS together?


Hi yes just make a bootable USB stick then put data lifeguard for dos on it. Also the data lifeguard for dos comes as a . Zip extract it then put the dlgdiag5.exe on the bootable USB stick. Once you boot from the USB it will give you a dos drive letter prompt so then to run the data lifeguard you would type in dlgdiag5 and push enter that should start the program.

I was able to finally create the boot usb stick with data lifeguard tools in it,.

I did a quick scan on the drive and I got read element failure error 007.

Then I did a full media scan and after almost 2 hours I got :

Too many errors found, please contact technical support, error/status code 0225

Then I proceeded to do a quick zero writting, after this process I got no errors 0000, then I thought the drive was fixed and proceeded to do the quick scan again to check it but now this time won’t finish, it’s stuck and even ALT X won’t kill the program, I runned it twice with no luck. This means the drive now is completely dead? what are my options now?

Hi your only choice is to RMA the drive or return it to where you bought it for a new one most places are 30 days. To do a RMA with WD  you can check the warranty status and start the RMA from here. http://support.wdc.com/warranty/index_end.asp?lang=en   . Even though it turned out badly you have learned many things good job on the boot USB.

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.

Today I decided to try the drive in my new PC and ran the boot usb with diagnostic tools and I got this message:


But I still can see it in the BIOS.

I guess now it’s getting worse because when I first built the PC detected the drive and attempted to install windows, now I guess is gone…