Warning! firmware update for mavericks kills 'my book studio'

Hello all,

well as it says in my title. Followed the Firmware Update supplied by Western Digital to make My Book Studio safe and compatible with Mavericks (which I have not yet updated to just in case).

Followed their procedure to the letter. Halfway through updating to my external drive a complete failure. The drive is completely dead. No lights, no display, no whirring… Absolutely nothing.

So emailed support, no reply. Read a couple of similar cases here on the forum. Phoned their help line. The brief outcome of the conversation was:

Me: ‘Hello, I updated to your Firmware as suggested and provided by WD. It has killed my drive’.

WD: ‘We are sorry about this. Your drive is 6 months out of Warranty so there is nothing we can do’.

Me: ‘But why would you provide a Firmware Update that is destroying drives. I am not the only person with this issue. Take a look on the forum, I have seen other cases’.

WD: ‘Updating the Firmware is sometimes a risk and seeing as your drive is out of Warranty there is nothing we can do’.

Me: ‘But I would not even have to update the Firmware if the Firmware was not already going to cause problems with Mavericks. If I want to use the drive safely on Mavericks I have to update the Firmware which you supply. Your Firmware destroys the drive. You are providing something which is destroying your drives. Why should I have to pay for a new drive because WD is killing my drives?’

WD: ‘I understand your problem but there is nothing we can do’.

Me: ‘So now I have to buy a HD Dock to try to retrieve my valuable files, which will cost me money. Then buy a completely new drive. And your company are not willing to offer me any sort of reimbursement towards a new drive?’

WD: No. Updating the Firmware is a risk you take’.

Me: ‘Where on the Firmware Update does it state that it might destroy my drive completely? If I had know that I would not have taken the risk!!’.

WD: ‘Sorry, there is nothing we can do’.

So that is my story with WD. A word of warning to you all if you are going through this process. As for me, I have to try to salvage my files and buy a new drive. One thing for sure, the next drive or any future drives will not come from WD. 

The quote on the packing of my now useless drive - “PUT YOUR LIFE ON IT”. Seriously… DON’T !!!


We are very sorry to hear that.

So, nothing works on the unit?

Check all the connections on the unit since the regular cases on the community are not showing this behavior.


unfortunately nothing works at all. I have tested the power and all connectors. The drive is dead. I don’t think this problem is a regular case but there are other people with similar problems if you follow this post:


I have had good communications now with a WD rep and we have come to a compromise. I am grateful that the company do take note of these posts here on the forum.

Just an update if anyone is in my position.

 I have scanned my drive in an HD Dock with ‘iSkysoft Data Recovery’, ‘Data Rescue 3’, ‘Remo Recover’, ‘Testdisk’ and ‘Photorec’. Where there was once 1400GB of RAW photographic files absolutely nothing remains. Not one single image.

Same for me, last November. 100% dead. I got the new one, the replacement today.

This has just happenned to me !! 1.5tb of back-up data unretreivable. All i was doing was what i was asked… to update the firmware ready for maverics. 

Mac wont now mount drive, can’t initialise it / format / anything. It is unrecognisable even in windows too.

Trouble is… this drive is a WD (RMA) replacement for another Studio that went bad just over a year ago and now when i look on the WD site the replacement drive seems to out of warrantly even thou i’ve only had it for 14 months )-:

Have filed a case but from what I’ve read I don’t hold out much hope.

NB  according to system info i have a 144.12 PB (yes petabyte) disk! - shame i can’t do anything with it

I have posted this already on a different thread on this forum but your actual drive might still be alive. See if any of this sounds familiar:


My case is the ‘Controller Bridge’ seems to be the part that is damaged. If I was able to get hold of one of these then I might be able to access my files. There is a chance the data is still on the drive. My problem now is where to get a ‘Controller Bridge’. Is worth knowing that these drives are encrypted which makes things a whole lot harder:


And the irony… a leading photographic magazine is doing a 6 page retrospective article on my photography. A lot of images are on this drive. One of their questions is ‘what is the worst thing that has happened during your photographic career ?’

I think I now have an answer.

I’m a photographer… been earning a living from my trade for too long - over 25 years, I used to shoot on film way back, then scanning negs but have been ‘shooting’ digital for the last 15 years… I am “a-n-a-l” (no shame) & have always backed-up my recent images with Cd/DVD (the early days of CD were scary!) but I have always trusted Western Digital with Hard-Disk responsibility…

Now here’s the rub…

Despite that i had purchased Western Digital for at least 15 years it’s only in the last few years notice a problem… I bought a MyBookStudio in 2010 -  it failed in 2012 & was promptly replaced with a new drive (not refurbished) under the 3 year warranty.  Now (Jan 2014) the replacement drive has failed too, but for different reasons…

I know something about computers having built PCs for some years but have thankfully avoided the constant updating by using OSX but I read in the news about WD problems with Maverics and waited till it seemed safe to update the firmware of the ‘My book studio’ in preparation for my new iMac running Maverics.  I had thought the WD update would be good, so prepared my - dare i say it ‘trusted drive’ to continue its ‘Time machine’ task on Maverics.

Sadly it hasn’t played out very well… I’m stuck here with a 1.5tb ‘time machine’ backup drive that is as good as a door stop - no recognition by computer, no lights, zilch… to be fair it tries to spin up for a few seconds then… nothing… and yes I’ve tried plugging it in and using a different cables etc… and yes I’ve even used windoze to try to get it working - BUT i haven’t taken the hard drive out of its little nest to smash it to pieces YET - nor have we been tempted to take it out and plug it directly into my Mac pro or a caddy - I might invalidate the useless warranty….I know it’s dead - very dead!!

But what gets me most is the ‘WD’ notion that a drive that is replaced because of failure or crappy firmware is not worthy of the original 3 year warranty from the date it had been replaced because the last one died.  I’m sure i could have worded that better;  The warranty only applies to the original purchase i.e. the warranty runs out for replaced drive at the same time as the one it replaced. - Apparently you can get round this buy ‘upgrading’ on your replacement therefore starting the warranty period from that moment - wish I’d been clever!

Sooo 1.5 tb of recent work lost…. but thankfully I’ve CD’s and ALL the time in the world (NOT) to transfer back to another manufacturer’s hard disk….

Seagate, Buffalo or LaCie prepare yourselves for my imminent custom & screaming bad things about Western Digital.

“Rant”???  - of course -  I’m a loyal customer & a disgruntled one at that.

Jules… my sincere sympathy. F2 is a  good mag (-:

If you do take the drive out of the casing (as I have done) you will have to remove the ‘controller bridge’ to make the drive fit into a Dock or a new enclosure. Your drive will appear completely blank as the data is encrypted. You need the controller bridge (the board with the power connector and usb/firewire ports) to read the data. This is the part that is dead on my drive. And this is the brick wall!

Thanks for your sympathy. Was tough and very expensive going back to a lab to get some old negatives and transparencies scanned for the magazine article (yes, like you I am very old school, shooting for over 25 years too). As for some digital shots I guess they are gone forever unless WD can come up with any help in getting a controller bridge…

All the best to you in your search!

so now i’ve heard it from the horses mouth…

from Western Digital - 

" …I would like to inform, that a warranty for a product from the service (RMA) is the same as the original product bought. So, if your product was purchased in 2010 with 3 years warranty, a replacement product inherits warranty of the original product. I would like to apologise for any inconvenience."


My reply below - 

'My drive was working fine before I updated the firmware on it in preparation for maverics on my new iMac.  It is now totally useless because of Western Digital’s firmware update it is un detectable by any computer - it had nearly 1.5tb of time-machine backups on it.  How on earth am I going to retrieve that?

It is more than just an inconvenience, it is a disaster!

If you feel that Western Digital can help me in any way please get in touch again very soon as I am now tempted to open the case, take hard drive out and and disassemble it - loudly.

Western digital… never again’


If you are keen to then back up your ‘back up’ drive in preperation for a totally useless drive after the updated firmware has done its work.

I am now going to prize open the case and try and find a way to get this drive recognised by anything… maybe the last WD Studio drive that failed has a controller bridge that works??? - Oh this is fun

If you do take the drive apart, like I did, it will still not be readable in another enclosure or HD dock. Although it is recommended not to put the drive in a HD dock as it can erase all data! The controller bridge holds the key. One thing it will confirm is that the actual drive is still alive or not. Then you can try the controller bridge route. I emailed a company in L.A about a replacement bridge with this response:

Unfortunately we are not able to tell you if this board is compatible or not. There are different way to do data recovery with various equipment. Please contact your local data recovery specialist.


So there are no guarantees about retrieving any data this way. Also I am a total novice to all of this and there is also talk about replacing ‘Bios’ chips to find your encrypted data. Way over my head.

I have to mention that I have had a good dialogue with a WD rep about trying to find a solution. I hope you and I both have some luck with retrieving some if not all data!

Same thing happened to me. My warranty expired just 2 weeks before the “incident”. I was denied replacement drive from WD representative in Croatia, and then I wrote a letter to Wester Digital via “WD Support Portal”. That was 7 days ago and still no response whatsoever… 

"Dear WD, 
I have a very serious malfunction of a My Book Studio (2TB model with Firewire800). Couple of weeks ago i was browsing your website for new updates and found that my My Book Studio is eligible for Firmware Update. Since this was new firmware (from December 2013) I naively thought that installing this update was a good thing. After all it was official firmware update for my external hard drive. Everything was fine up to a point when the Firmware updater suddenly crashed. “Ok, no problem, I’ll just start the updater again following the necessary steps”. That was when i noticed that hard disk was not reacting. The letters on the e-ink display started to fade away, and the disk was no longer visible by the computer. There was no way to use or “see” the hard disk. I tryed to unplug and plug again the power cord but with no success. 
My Book Studio was completely dead and utterly useless and has remained that way for the past couple of weeks. I bought the disk in Croatia (now part of European Union) and my 3-year warranty has ended just couple of weeks ago (i have a receipt, the disk was bought on 16th of December 2010). I believe it is completely unfair to have my disk dead just couple of weeks after warranty period (i was denied help by Croatian distributors “ASBIS” and “M-San” and told to write directly to you), and not to mention that the main reason for it dying was installing YOUR official firmware update! 
I have to inform you that I filed a report with “Croatian Association for Consumer Protection” ( www.potrosac.hr)) and “European Consumer’s Organisation” ( www.beuc.org), and was given reassurance that this problem was completely avoidable by your company and in no case my own fault. 
My problem is not with losing data on disk because I am aware of the potential problems with firmware update and the possibility of losing data so I had all of my data backed up before update. But there was no warning whatsoever that official update will kill my external drive and that i will have no right to a compensation! 

I expect your reply to be fast and favorable because whoever is reading this is also a human being and aware that this is not a way to treat your decades long customer, and it is exactly the right way to loose a customer and gain bad publicity."


Tried to update my MyBook Studio Elite for Mac, the one with the LCD on the front face. 

Same story here… after forcing my to download JavaSE6 to get the **bleep** thing to work, I began the updating. 

I now have nothing working… the drive does not even power on, the small silver light does not get on.

How can a company like Wdf release such a messy thing and not even care to replace the drives that are now defective because of them not being competent at writting decent software ? 

I am MADLY FURIOUS AT THEM !!! And somewhat at me : it was working all right beforehte crash… Why, why, whyn on earth did I want to fix something that was working ?

CONCLUSION : Western Digital ? Probably never again as external drives…