Want old firmware - My NET N900 Central Router

For quite a while, my firmware was on version 1.02.02 (or something like that) – the original firmware out of the box.  I resisted the temptation to upgrade firmware button for a long time because the router just worked. Absolutely zero issues.

Then one day I clicked the button.  Now I’m on 1.07.16.

Ever since it’s been absolutely horrible.  At least once a day I have to toggle (Advanced/Wireless) the 2.4 GHz wireless off and then back on to wake up all my devices.

I’ve tried turning off the 5Ghz band, WMM QoS,  FasTrack Plus QoS, and any other “feature” that I can find that I don’t actually need.

Where do I find 1.02.02 firmware?  I can’t seem to find it via WD’s site and I don’t to install some *nix variant to build the thing from sources.  I just want my original firmware back.

I’m pretty close to just throwing the thing away and getting another brand.  I didn’t buy the WD device to spend every waking minute trying to troubleshoot the technology.

Any help appreciated.

Thanks.

Hello and welcome, 

Try  resetting the My Net back to factory default, this will remove any residual configurations that may be causing conflicts within your network from an update that did not fully reset upon reboot of the unit. Check page 70 of the manual for the steps. 

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705074.pdf#page=74

Thanks for the reply but you didn’t answer my question.

I’m done playing games with the new firmware.  I want the old firmware.  How do I get it?

Hi again, unfortunatelly older firmware versions are not available on the WD page, I recommend you to contact support directly. Check the link below. 

http://support.wdc.com/contact/contact.asp?lang=en&ct=networking

There is a older version on the cd but its 101 not the 102 that came on the device .

This is how…

they still host the downloads, just not publically display the link

goto wd download page for your router, hover over the download link, it should be a zip file.  Using common sense the old follow the same format as the new regarding the address.  Copy the link, paste it in your address bar, modify the last numbers to reflect the firmware you want.  I have sucessfully downloaded all previous n900 non central this way.

Thanks N-SR20-M.

This works for the N750 and N900 non C as well. (In fact, it often works for many downloads from larger sites for previous versions of software)

Hi,

Here are the links to all firmware versions directly from WD site:

http://download.wdc.com/nas/My_Net_N900_Central_1.07.16.zip

http://download.wdc.com/nas/My_Net_N900_Central_1.06.18.zip

http://download.wdc.com/nas/My_Net_N900_Central_1.05.12.zip

http://download.wdc.com/nas/My_Net_N900_Central_1.04.11.zip

http://download.wdc.com/nas/My_Net_N900_Central_1.04.08.zip

http://download.wdc.com/nas/My_Net_N900_Central_1.03.11.zip

http://download.wdc.com/nas/My_Net_N900_Central_1.02.02.zip

However, version 1.07.16 works best for me, after I’ve discovered that is mandatory to 1) reset router to factory settings (Advanced Settings -> Admin -> System) and 2) Restore the Internal HDD (Advanced Settings -> Storage -> Format -> Restore).

It seems that restoring the internal HDD doesn’t erase your files, although it says it does (do at your risk).

1 Like

I had the same problem after pressing the Update Firmware button … the router wouldn’t work after the upgrade. After reading Rapha’s response, I reset it, set it back to factory defaults, and then manually uploaded the 1.07 firmware and it’s working great now.

I was just about ready to throw it against the wall.

Thanks for saving my router Rapha. :slight_smile:

Thanks for the links…two issues…the version 1.02.02 link isn’t working…and…as long as we’re at it, I believe there is a firmware 1.06.28 out there as well…and yes…found…link below.  Thanks for all the ones you posted…much obliged.

http://download.wdc.com/nas/My_Net_N900_Central_1.06.28.zip

Merged with prior post…thanks

I wish this fix worked for me… Its now Jan '14 and out of the box router setup as easy as can be. Setup WD2GO and everything worked fantastic until I updated my firmware. Now every time I go to WD2GO and try to enable it I get the same error, UNAUTHORIZED. Nothing I do will fix this problem. I returned my first unit and bam received another one today and the exact same problem. Seriously no joy here.
Now the router seems to work fine but I actually wanted to use the WD2GO feature for our families smart phones and tablets.

Hi , i had a mynet 900 , then got a replacement, for another mynet 900 , and then got a replacement for a mynet 900 central .

The issue happened on all the routers. 

my solution was, using 5gh wifi.

using 2.4gz  worked for couple of hours and then , “Limited Conection” on windows , had to disconect and re conect .

the bad thing of that is , i cant left anything downloading, cause it will stop downloading.

im not going to start a support case with wd anymore, as is seems to be a commom issue.

by the way, no complains at all with wd support, they were great all the time

I hope someone find a solution soon.