Vudu & Hulu not showing on Aussie Hub w/ Unblock DNS?

So the hub is set to US EST as time & location with Unblock US DNS, the WD special offers shows up with Vudu coupons & other offers… but I can’t get all the good US Apps to show up in services, I have already reset to factory default many times. I am located in Australia and those apps work fine on the PS3, 360 & BD Player with Unblock US DNS. I would just be happy to get the Vudu app working so I download my purchases to the hub. Any help would be appreciated.


not sure I haven’t looked into how WD does region authentication, but a couple of possiblities

  1. WD connected while not using unblock us and the region was cached

to clear this you would have to hack into the device and wipe /conf

this is beyond the scope of this forum

  1. I supose WD might partially authenticate based on serial number for devices sold is specific regions

but again, I haven’t looking into this

The player determines the services to show based on your IP address. Unblock does not change your address so the WD servers know you are in Australia. You could try resetting without any connection to the internet. Set up your unblock etc and then connect.

hi guys, thanks for your support. I tried resetting while internet was disabled and reentered dns info , but didn’t work. I then passed thru a vpn server with a us ip address like i do with the 360 & PS3 and after resetting the wd no new apps appeared. I also rolled back a few firmwares with vpn on and still no luck.

back to #1 above

if the WD cached the region to one of the files in /conf

you will not be able to clear it, even a factor reset will likely not clear it

you would have to hack in at cmd line level and delete the directory

again, beyond the scope of this forum