vsFTPd old version and not support SSL

Hello,

Is possible to integrate the new version of vsFTPd now at (vsftpd-2.3.2) with SSL support?

currently version on NAS is vsftpd-2.0.4 seems expired.

Thanks.