VPN on same network as WDMyCloud may cause MC to fail!

If anyone here with a WDMyCloud who also run VPN please report if you have experienced any slow responses or complete failure to respond from their WDMyCloud. I’m trying to find a way to isolate this problem which I’ve finally tracked down to my use of VPN on the network. It makes the WDMyCloud so slow that it requires a POWER OFF reset to get it running again.

My setup: 4 computers on the LAN (3) Windows 10 Pro and (1) Windows 7 Pro on a Gigabit LAN. ASUS RT-N66U router, high speed cable internet (20 MBs). The VPN is used during Torrent downloads.

Anyone with any ideas?

Paul

How is the VPN setup? Is the VPN server on the local network or remote network? Is the VPN client or server running on the Asus router or one of the local PC’s? What VPN are you running (PPTP, OpenVPN, etc.)?

If you are using your Asus router as either the VPN server or VPN client perhaps its a router problem.

Answers: VPN on local network. Running VPN client only. VPN running on one of the Windows 10 systems when required (i.e. only when needed). ASUS router is not used for any VPN services.

I’m using PIA for the VPN connection. I was previously using PureVPN and I was experiencing the same sudden decline in WDMyCloud response but hadn’t at that point identified the VPN as a potential trigger for the WDMyCloud issue.

I can’t be sure that VPN activity on the LAN is somehow directly affecting the WDMyCloud (why should it?) but the immediate change in WDMyCloud functionality when I start a VPN session is undeniable. Even after shutting down VPN connections and terminating the VPN process the WDMyCloud continues to be slow or virtually non-responsive until I power down the WDMyCloud and restart it.

It could still be a Windows issue of course. Who knows. But for the moment when ever I run VPN I must immediately follow it with a power down/reboot of the WDMyCloud.

Strange to be sure. ???

Paul

Do you have a non Windows 10 PC that you can run the PIA VPN on to see if its confined to just Windows 10 or is a problem with other Windows OS’s?

Make sure Windows 10 is updated to the latest updates. Apparently Windows 10 previously broke PIA if the following thread is any indication:
https://www.privateinternetaccess.com/forum/discussion/16864/solution-windows-10-build-10049-breaks-openvpn-there-are-no-tap-windows-adapters-on-this-system

If you have Remote Access enabled on the My Cloud and or are port forwarding ports to the My Cloud within the router, what happens if you disable Remote Access in the My Cloud and (or) remove the port forwarding assignments while running the PIA VPN?

At the moment I don’t have a non-Windows system (other than Android and iOS) so I may have to fire up my VirtualBox with a Linux OS and try that.

All my Windows 10 systems are up to date and PIA has been running with no problems since last November. But, saying that, I’ve had intermittent non-responsive WDMyCloud issues since way back - maybe even as far back as November. Interesting.

The WDMYCloud is running as only a NAS; no Twonky enabled, no REMOTE enabled and no ports forwarded at all in the RT-N66U. Also, no external USB drive attached.

Still a mystery.

Paul

UPDATE:

Although I cannot yet 100% confirm these findings, it seems that the WDMyCloud is prone to slow or zero response/transfer speeds when it has ‘seen’ VPN traffic on the local LAN. It seems to befuddle the firmware somehow and it just slows down transfers and response time.

Background: I have been experiencing this phenomena for several months and I was getting tired of continuously doing a POWER OFF/4 Second Reset several times a week, Now, however, I may have a work-around.

I have isolated the WDMyCloud on a Gigabit Switch such that it is not in the same segement as the two computers (Windows 10 Pro) running periodic VPN services.

This change has worked for the past two days. That’s a record for my LAN!

I’ll keep you posted.

Paul

EDIT: Current ‘new’ transfer speeds are 84 MBs read, 56 MBs write. Quite acceptable.

Seven days and no slow down! And no reboots!

The WDMyCloud has been up and running now for 7 days since I moved it’s network connection OFF my ASUS RT-N66U router and connected it to a Gigabit switch. During that time I have run VPN services several times on the network.

So, its still a mystery as to why the WDMyCloud gets trashed when it’s connected to the same router as the VPN traffic because the VPN traffic is not in any way related (or routed) to the WDMyCloud.

Still hopeful that it’s now fixed as far as my configuration is concerned.

As you can see, the speed is more than acceptable.

Paul

Any way to test if it is the ASUS RT-N66U router and not the My Cloud that causing the trouble? Like use another router to test with?

It is strange that the My Cloud would have problems being on the same router that is passing VPN traffic. Wonder if there is a problem with the router firmware and how it handles VPN traffic on the local network if there are multiple devices listening for open ports (possibly involving VPN ports).

Unfortunately, that would require a teardown of my setup and a second router. I don’t think I’m ready to do that.

I am somewhat suspicious that it’s the WDMyCloud and not the ASUS router. I have had two firmware upgrades on the router since last November and the symptoms didn’t change. No other symptoms appear on any equipment on the LAN when I use VPN - just the demise of the WDMyCloud.

I’m still thinking of ways I can prove this.

Paul

Don’t know if you ever got this figured out but I’m having the same problem (have had for sometime) using a Mac compute. So I know it’s not just a Windows issue. My WD My Cloud PR4100 is connected to an ethernet router which everything else is connected to, i.e. computer, cable modem, Orbi wireless router, etc. Not everytime, but frequently after I use my remote connect VPN (I subscribe to a VPN serve) the WD loses connectivity when I try to connect to it on my cell phone using the WD app. I have to reboot the WD drive. Just restarting the computer or disconnecting from the VPN doesn’t do anything. The drive itself must be rebooted for it to regain connectivity. What I did was to use a wifi connected smart switch and if I HAVE to access the drive I simply turn the switch off, wait and turn it back on. I absolutely hate doing a cold shutdown of the drive but it does work under emergency circumstances.