VOB files from internal drive play choppy or not at all

I’m a brand new WDTV Live Hub user with the latest firmware.  I’m having trouble playing raw DVD files.

Here’s what I did:

  1. Put DVD in Win7 machine.

  2. Copied the TS_VIDEO folder to the PC hard disk.

  3. Copied the TS_VIDEO folder across the network to the WDTVLiveHubinternal disk.

The tree looks like this as viewed from the PC (looking at the WDTVLiveHub network share)::


  Harry Potter and the Sorcerer’s Stone/

    Harry Potter and the Sorcerer’s Stone.jpg  (apparently created by Get Content Info)

    Harry Potter and the Sorcerer’s Stone.xml (apparently created by Get Content Info)















  1. On the video menu, I can navigate to DVDs.  The disk cover thumbnail appears next to the directory.  I can navigate into the TS_VIDEO folder where I see a “Harry Potter and the Sorcerer’s Stone”  video object.  If I hit play at this point I get:

Some audio, with no image for a short while (it should be playing the pre-menu intro).  When the DVD menu starts to play I get really poor chunky rendering (very pixelated and stuttering) of the menu.  I can interact with the menu and select “Play Movie”.  At this point the video freezes and I get audio only.

  1. If I pull a VOB out of the tree and try to play it directly, I get either

  a) Really chunky video play back and audio

  b) Audio with a blank black screen.

What am I doing wrong?  Or do I have a bum unit?

What did you use to DECRYPT the DVD?


I used DVDshrink to create an uncompressed (no recoding) ISO file.  This file seemed to play… except the aspect ratio is wrong.  The image is stretched horizontally.  I see this with MKV and other formats ripped from DVD also.  Since the film is 2.39:1 (some say 2.35), and the DVD format is natively 720x480(1.5:1), I’d expect a letterboxed (2.39–>1.5) and pillarboxed (1.5–>16:9) image.  Instead I only get letterbox with the width stretched to the full width of the TV.  (Imagine the pillarboxed display being stretched sideways until the pillars disappear.)  The resulting ratio is something like 2.8:1.  I wouldn’t mind so much if it were being stretched equally in both dimensions.

The TV (Sony Bravia no internet) supports 1080 HD resolution and the WDTVLiveHub is connected via component cables.  The WDTVLiveHub setup is set to use component outputs at 1080i. The TV display options ‘act’ as if the input is being provided as widescreen (there are different display setting depending on whether it is a wide or 4:3 input). 

FWIW: A really nice feature would be an ‘info’ display which shows the current resolution being generated by the Hub to isolate problems between source and destination.

I guess I can live with making ISOs for every DVD, but incorrect ratio is a non-starter.  Is there a step-by-step how to make a DVD work on the Hub tutorial somewhere?

Nothing, I guess I figured the Hub would do that just like the DVD player does.  See update (above)…

Lentil wrote:

Nothing, I guess I figured the Hub would do that just like the DVD player does.  See update (above)…

Well, you have to use SOMETHING to decrypt it, because all commercial DVDs are copy protected.   If you were just copying the raw VOBs, then there’s no way the WDTV can read them since they’re encrypted.

I don’t know if DVDShring does that or not.

Anyway, I have never had an issue with the aspect ratio getting screwed up on mine, so I can’t figure out what the issue would be.   It almost sounds as if the Anamorphic Flag is getting incorrectly turned ON.    Anamorphic is the ONLY format that a DVD player should stretch on a 16:9 display.

I would suggest you go download the free trial of DVDFab and see if you get better results with that.

TonyPh12345 wrote:


I don’t know if DVDShring does that or not.

Ya, DVD Shrink is old and no longer supported, but it does De-CSS when it’s making a backup.  It just croaks on any newer protection schemes.

I’ve never used it to actually “shrink” a dual-layer disc down to fit on a 4.7… all I’ve used it for is decrypting DVD’s to a VIDEO_TS folder on my HD so that I can Handbrake the files.

I’ve never noticed the aspect coming up wrong, but then I’ve just had it create VIDEO_TS and not .iso.

I do concur, that free DVDFab might be a better choice, since it supports decrypting newer schemes.  A 1:1 clone should leave the aspect untouched (but then so should DVD Shrink :wink:)

Try the free MakeMKV instead. I convert all my discs (DVD and BD) to MKV and they play superbly on the Live Hub. Currently I use PavTube’s ByteCopy to make MKVs as it preserves original aspect ratio and multi-channel audio.

I tried MakeMKV, but ended up with a bunch of smaller files instead of one continguous one.  Perhaps I’m using the wrong settings, sicne I thought the MKV container would allow multiple components to be embedded.  Am I correct in understanding that if I want DVD menu functionality the only choice is to use ISO or edit:TS_VIDEO VIDEO_TS folder with VOB?

At this point I’m not worried about file size, so I’d prefer the conversion be as ‘raw’ as possible.  I’m saving compression for future experimentation, but figured I’d start with DVD in == DVD out.  :slight_smile:

Also, should I expect the resulting ISO’s to work properly (that is… act like a DVD) when played from a network source in lieu of the internal drive?

I’m storing my DVD movies on the Hub the same way (meaning VIDEO_TS folders, no additional compression).

To decrypt them, I’m using DVD Decrypter and I never saw the screen size problem you mentionned. You could perhaps make a try with this software (it is easy to use, no parameter to manage, only the destination disk/directory to chose).


PS: don’t worry, when you close the program, if you have an error message. It’s seems to be “normal” and does not affect the copy of DVD on disk.

Ok, so I played around with the resolution settings on the Hub to no avail.

Eventually I tried the composite output and the ratio was correct. 

I accidentally selected HDMI switching back to component and managed to lock myself out of the GUI.

Another nice feature would be the ability to access the setup menu from  the web remote…

In any case I pressed the reset button for a long time and saw no obvious reaction.  I walked away for a moment and eventually it came back.  Even though I’ve put the settings back the way I had them (as much as I can remember), all is well on the ratio now.

The files I had ripped before using DVD Shrink worked fine.  I’m using DVDFab now and it also works great.

Thanks all.