View Files on Dashboard

When I open on the Dashboard for My Book 2TB theres no longer an option to view files. It wont open from the option to do so on the shortcut on the bottom right of my PC either.

Any idea why it is there any more or why it isnt opening?

Please help.

It was removed from the latest firmware b/c of the Java security issues. Search for the release notes.

Thanks for your help but how can I view my files now?

Access it directly – which is what most people always did.  (I never had any need for that Java helper…  waste of a lot of keystrokes to have to log into the MBL and then click something…)

Just go into Windows Explorer and enter the URI to your share, such as:


Thank for this but when i try that nothing happens.

I open up a window, type in //mybooklive/public and then nothing opens apart from a Chrome webpage saying opps.

Is something seriously broken with my book or my PC?

Not sure if this will help but if you changed the name of your drive from simply ‘MyBook’ then you will need to use that in the URL instead.  ie \lestersdrive\public

I find it easier to just navigate to my drive using My Computer. It appears as drive Z: If you map it as a network drive (go to my computer and select ‘Map Network Drive’ and then browse it should find your drive. You can then explore it like any local drive.

It’s backslashes. Not forward slashes. And you have to use EXPLORER, not chrome. Chrome has no clue how to access shares.

Thanks for the help again guys but I hope I’m not sounding like an ■■■■■ when I say I’m still having problems.

I’ve tried that way with back slashes and its still not finding it.

This picture shows what comes up when I input \MyBookLive\Public into Explorer.

And this it to show that what I am inputting is the name of the device.

Any more help?

I’ve tried to “map” it as well but thats not working. 

I’m getting really confused here. 


do your computer and MBL have the same workgroup name?

I’m not sure. How would I find out?

I’m doing this all wirelessly if this helps. My PC is wireless and MBL is attached to the wireless router.


Just looked and both have the work group name WORKGROUP

Still confused.

See if this tutorial for troubleshooting helps:

Quick View might help you out.

Look at this post