Video streaming stops after 20 -30 minutes

Hello to all,

I have a following problem. 1 year ago I bought My Cloud EX2 and I mostly use it as a storage for videos and for watching them on Samsung TV (UE32J5502). For several months everything worked fine but at some point I started experiencing issues with video streaming. Video stops playing after some 20-30 minutes and it says ‘connection lost’ and I have to play the video from the start again. Very annoying. Maybe the problem started after some firmware update, just my guess.
I saw several discussions about this problem on Internet but haven’t found any clear answer so far. Also maybe because my English is limited :slight_smile:
Could anyone please help me?
Thank you very much in advance.

Try setting up a Static IP on the Cloud.
https://support.wdc.com/instructions/?ID=11384&lang=en

Thank you, I will and then I´ll let you know in a week or so.No time to watch videos during the week :slight_smile:

I had been wrestling with this for awhile. I noticed that the IP shown by the TV’s network settings did not match what Twonky showed the TV at, so thought that might be the issue. I had seen the solution of assigning fixed IP to the TV, but unlike Twonky which showed TV as connected device, my AT&T router/gateway did not show the TV as a connected device. Suspecting firewall issue, I started with just turning off the Windows 10 firewall and presto, TV now showed as connected device (as IP/localhost for whatever reason), and remained there after turning firewall back on. I then used IP allocation to give TV fixed address, using the one that Twonky was showing it at just to be safe without restarting media server. I then set up TV to use this fixed IP. By default, the TV now wanted to use the media server access IP as Gateway rather than router access IP, so switched that back to router access IP as before, leaving Subnet Mask and DNS Server info alone. Connected to internet, and was able to watch movie all the way through from my wifi connected MBL without disconnecting for first time in ages. And without any lengthy or recurring buffering either. Also noticed speed boost with loading and using Netflix. Hope this helps.

Thank you Mike. I’ll try to follow your instructions the coming weekend. I hope I’ll make it :slight_smile:

I have an exact same issue but wasn’t able to fix it. Did it work for you?

Feragui, static IP setting on the cloud didn´t help. Still the same problem.

Mike, sorry if I didn´t get it right, but shall I note the IP setting of MyCloud and use EXACTLY the same as a default setting on my TV?
Thank you and sorry again, I´m just a final user and not an IT specialist.

Just a change to static IP on WDMyCloud as described here https://support.wdc.com/instructions/?ID=11384&lang=en didn´t help.

No, leave the WD dashboard settings out of it, put back how it was and forget about it. Mine is still on the default “DHCP” setting. You want to use your router settings to assign a fixed IP to the Samsung TV that is WITHIN your router’s DHCP broadcast range, one that your router might assign using DHCP. This should be under “IP allocation” or similar. Your router will still use DHCP and assign IPs on its own to other devices, but your TV will always get the same IP from the router. Then on your Samsung TV, tell it to use this same static IP. For me it auto-populated the other fields, which worked, although I changed the gateway IP from the WD server access address to that for my router. If there should still be an issue, make sure the server program on your WD (in my case, Twonky) is also seeing your TV at the same fixed IP you assigned. Has been working flawless for me.

I have twonky server 8.5 installed on my WD My Cloud EX2. Here is the solution that works for my SAMSUNG BD-C6500 player. No disconnecting any more:

  1. Enable Secure Shell connections (SSH) on your WD My Cloud EX2 device. (Settings -> Network -> Enable SSH)
  2. Connect to your WD My Cloud EX2 (… or another server you use) via SSH. I use WinSCP for this task (https://winscp.net/eng/download.php)
  3. Find twonky server configuration file twonkyserver.ini . It is located here on my WD My Cloud EX2 device: /mnt/HD/HD_a2/.twonkymedia
  4. Edit the file: twonkyserver.ini
  5. Find string: ssdp_beat_time
  6. Modify settings like this: ssdp_beat_time=3620 (default value was 1810 so I doubled the default value)
  7. Save the file
  8. Restart your twonky server

That’s all. It should work also for you.

1 Like

Thank you very much for your help. I ended up at the point No.2 :wink:
Can you please advise me as how to connect to WD My Cloud EX2 via WIN SCP? WIN SCP installed and asks me for a hostname, what should I type there?
Sorry for asking such stupid questions but I didn´t use SSH before.

You can use your IP address instead of hostname.

1 Like

Thank you very much. In by you mentioned file twonkyserver.ini I only found the following setting related to SSDP:

Port number for the SSDP heartbeat. Default: 1900

ssdpheartbeatport=1900

I din´t change it yet as I don´t wonna do anything wrong. Is this the value that should be changed?

Thank you

The right parameter is ssdp_beat_time
If there is no such parameter then add those lines in your twonkyserver.ini

# Set the SSDP heart beat period parameter
ssdp_beat_time=3620

But I’m affraid that this parameter might be new in twonky server version 8.5 that I installed manually.

1 Like

Thank you. Is there any exact position in the ini file where I should add the lines or the position doesn´t matter and I can just add it to the end of the file (as a last line)? I don´t wanna make a piece of dead hardware from my twonky server :wink:
And can you please advise me where I can find my actual twonky server software version?

You can put the parameter ssdp_beat_time anywhere in the twonkyserver.ini
Your actual twonky server version is displayed on twonky server status screen http://hostname:9000 (where hostname is your WD My Cloud IP address). There is probably twonky server version 7.2.9-6 bundled with actual WD My Cloud firmware 2.11.168.
Latest (paid) twonky server version for current WD My Cloud EX2 is here http://www.twonkyforum.com/downloads/8.5/twonky-WD_MyCloud_02.xx.xx-arm-8.5.zip
For other hardware/firmware/twonky combination you can search here http://www.twonkyforum.com/downloads/
The basic manual how to install latest twonky server manually I found here https://community.wd.com/t/uprgarde-of-twonky-dlna-server-to-8-3/176393/5

1 Like

My current firmware version was the latest version 2.11.168. So I edited twonkyerver.ini according your reccomendation (added “# Set the SSDP heart beat period parameter ssdp_beat_time=3620”) and restarted WDMyCloud.To my big surprize it seems to be still alive and working after my crazy playing :wink:
Within a week I´ll let the folks know if the issue was solved. I only have to find a time to watch some movies.
Thank you for your help, willingness and patience!

You can do quick check if the parameter works:
ssdp_beat_time=300
This small value should lead to nearly immediately disconnect.

Thank you. For now I´ll let my wife and kids test the streaming by watching movies from WDMyCloud. They were sick and tired of endless disconnections, thanks to you I did my part by the modification and now it´s on them to check it out :wink: