Video problem with 3D now I have gone to a NAS device

I have changed from a HDMI connected media box to a NAS, a WD mirror. 

My old media box was working fine (WD elements play) but I wanted the extra capabilities and HD size increase.

3D films now exhibit white flashing continually on my projector when coming from the NAS.

I have a WD mirror, connector via a TP link gigabit switch to my panasonic BD160 bluray player which feeds to my AV amp (Yamaha rx-v3067) via HDMI. 

From my Av amp to my panasonic ea7000 projector again via HDMI.

The bluray player and av amp are connected to network.

The same film without 3D activated on projector plays fine (though in Side By Side format).

A 3D film on bluray from same player plays fine on the projector.

I am using cat 5e cables and are all short runs. 

The projector is on a longer 8m or 10 m HDMI cable, this has worked fine for many years with everything.

The control of the NAS is done via the network functions of the bluray player.

Suggestions please, thanks

I believe there is a network traffic bottleneck somewhere. I understand your switch operates on Gigabit mode, however, if this is indeed the Ethernet port of your unit…

…Then it uses a 10/100 (Megabit) Ethernet port, which would create a bottleneck for LAN 3D playback.

Thanks I need to think on this.

There is nothing really on the network (Bluray player, av amp, and NAS).

I bought the giga bit switch to allow the wifi router (which has 10/100 ports on) to be distanced from the router.

I can stream the same film to my projector in 2D mode without any flashing, however when I turn on the 3D on my projector the flashing starts up.

 (the 3D activation is just a simple as telling the type of 3D it is, in this case side by side.)

The panasonic bdt160 is DNLA certified. (it does use 10/100)

The My Cloud doesn’t know the difference when your projecter is in 2D versus 3D – it doesn’t even know what the file is.   The issue must be with your projector – though I’d be hard pressed to understand what that is…

Your right its just a data file as far as the NAS goes.

I do think this is a possibilty that the projector could be an issue.

The only thing that makes me hesitant is the same films from a WD elemts play (via HDMI directly to AV amp) work fine.

Along with bluray discs themselves are ok.

What I can do thinking about it is transfer a 3D film onto a USB stick and plug that into bluray player so the network is bypassed and see what happens.

Really scratching my head on this one.


SO I copied a 3D film from my mirror to a USB stick.

Plugged the USB stick into my bluray player (same one used to control mirror).

The film worked fine in 3D, no flashing.

SO its only when it comes over the network there is a problem.

So the plot thickens.

The USB stick with the 3D film that plays fine if plugged into the bluray player when 3D is enabled on my projector.

Tuns out the NAS can play attached USB devices as well, so I plugged the USB stick into the back of NAS and the same problem occurs when 3D is enabled. White flashing on playback when 3D enabled.

So using the NAS and 3D does not work in my settup.

Still not resolved this.

I sent my projector away to have the firmware updated to the latest version.

Got that back last night but unfortunetly the problem still exists with flashing on 3D films when coming from the wd mirror.