Video playback turns to slow-motion with no audio

Hello all,

Well I have a brand new WD TV Live Plus HD Media Player running 1.06.16_B.

Suddenly when I’m a few minutes into a movie, the playback suddenly slows down to slow-motion and I have no audio.  It sometime resumes normal playback randomly, but often it stays this way until I stop and restart the playback.   If I stop the playback and restart it, the problem clears for a few minutes and then returns.  Pausing does not clear the problem like stopping and restarting does.  Needless to say, it could take all day to watch lord of the rings.

I’m using an approved USB 802.11n NIC and connecting to a Seagate FreeAgent USB external drive on my network.  I use Boxee in another room and it has no problems with playback of the exact same movies.  I am a video conferencing engineer with an MCSE and can assure you that my network connectivity is not the issue.  I also want to note that Netflix movies stream without issue to my WD and have no problems with playback whatsoever.

I have taken forum suggestions from other people with this problem and downgraded my firmware to various versions, but each is still having the same problem. The firmware versions do change the severity of the problem, but none have resolved it.  It seems like there are enough people reporting this issue that it would be addressed by now.  Is this something that is being worked on or should I just return the WD and get another Boxee?  I really like the WD because of the size, but it does me no good if I cannot watch any of my movies.

  I am a video conferencing engineer with an MCSE and can assure you that my network connectivity is not the issue

Well, I’m a continually re-certified Cisco network engineer at the NP/DP level (since 1998) and I would think your network connectivity is the issue  :)   Battle of Titles and all.  ;)

By far, the most common reason for this is insufficient bandwidth on your network, especially since you’ve ruled out a firmware-specific issue.  It’s definately most evident when using WiFi.

Is your Boxee Box using WiFi too?    The Boxee from my own experience has bigger jitter buffers and is better suited to dealing with poor network conditions than the WDTV…

It also has a lot to do with the bitrate of the movies you’re playing.   My WIRED boxes can stream un-recompressed BluRays (30 - 40 megabits per second) with no issues.   My 5.8GHz 802.11n attached Hub can stream MOST of them, but a few of them do cause the stuttering you describe (when burst rates exceed 50 megabits per second.)  So can you tell us more about the exact types of media you’re having problems with?

Is your WiFi N adapter 5.8 GHz or 2.4Ghz?

NetFlix can’t really be used as a comparison, because NetFlix uses multiple different encodings to accomodate the slower WAN links for many users, so it will measure your bandwidth and send a stream that shouldn’t over-run the network.   It can even adjust mid-stream when conditions change.

Well as a ‘a video conferencing engineer with an MCSE’ I would have expected you to post more relevant information.


  1. The mediainfo for the file(s) you are having problems with.

  2. What is your Seagate FreeAgent USB external drive plugged into?

  3. How are you sharing the media from your Seagate FreeAgent USB, SMB or DLNA?

  4. What device/computer is doing the sharing?

  5. How is your Boxee unit (that you are comparing the WD TV to) connected to your network, wired or WiFi?

Sorry for not including more information as I thought this was a known issue after reading several other threads.
Also sorry to offend by including some creds. I simply didnt want the equivalent of “did you reboot” for responses.

Here is a little more information on my setup:

Linksys WUSB600N Dual-Band Adapter on the WD.
Linksys WUSB100 RangePlus Adapter on the Boxee.
Linksys WRT350N router running the latest DD-WRT firmware.
My Seagate is connected and shared from a Windows 2008 Server (Standard Edition) on a Dell PowerEdge T310 Tower Server. No DLNA, standard Windows file sharing enabled.
I have tried mainly ISO files since 90% of my collection are movies I have burned to ISO images.
I have also seen it with other files as well though, like AVI for instance.

My WD is in my bedroom which is literally the next room from my router and always shows full signal strength.
My Boxee is on the other side of the house.
I use the “network shares” menu option in the WD to locate and play my movies.
As I was saying, the firmware versions definitely change the severity of the issue.
I’m sure I left stuff out, but I’m also sure you’ll let me know about it too.

I’m more than willing to load test code on my WD if it would help you diagnose.

The problem you described sounds very much like a network problem so we need to identify where the issue is.

Have you tried a wired connection between the WD TV and your router?

If this connection does not exhibit problems then perhaps-

  1. The performance of the WUSB600N driver in the the WD TV is sub-par.

  2. The performance of the WUSB600N adaptor is sub-par.

  3. There is a problem between your router (WRT350N) and the WUSB600N adaptor

4)  There is a performance issue between the WD TV and your  Windows 2008 Server

Also are these ISO’s DVD or BlueRay? Which device is the Master Browser?

ISO’s are DVDs and my Win 2008 server is set as my Master Browser.  So I did a little more testing…

I swapped the USB adapters between my Boxee and my WD.  My Boxee continued to play movies without any issue.  The WD continued to see the same issue.  That means two different Cisco adapters are seeing the same issue on my WD and those same two adapters work fine on my Boxee.

Now since the rooms are literally next to each other, I tried the wired connection. Ran a long cat 6 around the corner and set the connection type to wired.  The wired connection worked fine.  No playback issues whatsoever.


Wired worked, so streaming over wireless seems to be the issue.

Changing the wireless adapter used did not change the results.

Boxee using those same adapters and accessing those same movies works without any issue.

Obviously as was mentioned in another comment, the Boxee handles the stream differently than the WD.  And/Or the WD may not be utilizing the adapter drivers as it should.

Anyway, sounds like we’ve isolated the problem down to a couple of potentials, but is there anything that can be done about either?  Any other tricks?

Hi everyone.

My WD TV Live media player does the exact same thing. I was searching online to see if anyone else had the same problem and I found this thread. It does not matter which hard drive we use, which video file we are viewing, it just starts going into slow motion about 20 minutes into the film or TV show. We watched these same programs succesfully for about 6 months before it started happening. We have now given up using it as we cannot view anything without it happening.

We have a USB connected hard drive and have it connected to our TV via the AV cords. No Wifi or anything like that.

I am ready to throw this thing out, but if there is any way of fixing the problem, I obviously prefer to do that if i can.