Video Bug after updating firmware


I was very pleased about my WD TV Live product, but, yesterday i linked it to internet to access files from my computer.

I saw that there was a new firmware update, so i updated to the new version 1.06.15_v.

After i do that i tried some internet stuff as facebook and youtube and it was funny.

So, i entered on a media server on my network and played a movie. result: a little frame with the video at the right side of the screen, and the “loading circle” at the middle of the screen ( same using a pen drive). I tried to reset, to restore the default values… and nothing worked. so i came to this forums searching for something. i read something about the “roll back firmware”. So i did to version 1.04.31_v

after that, same problem, so i restored the default values and restart the WD TV Live. Result:

same as before, but at least the image is in full screen.

In both case, if i press the “home” bottom, it goes to home, but the audio still plays. any other bottom does nothing.

thank you for the support

( and sorry for the strange English)

João Pedro Borges

Try something simple like restarting the router. If that doesn’t work try to setup the internet connection with a manual IP.