Very slow?

I had to undelete a bunch (don’t ask…), so figured I’d get a 3TB Mycloud to manually undelete to, and later will use it as an auto backup. Attached it to a gigabit switch, which the computer (Windows 7 Ultimate) is also wired to. Both computer and Mycloud have static IP’s. Took days to undelete whatever I found onto a new folder on the Mycloud. Then and now file operations are frighteningly slow:

Takes ~3 min to load the file list in Windows Explorer;

Once a folder copy back to the computer is started, it “thinks” about the operation for over a minute, then copies very slowly, ~8 MB/ *minute* (not second). (Maybe slightly better on larger files);

Some folders fail to copy, saying “The specified network name is no longer available”, sometimes retrying multiple times works;

Connecting to the Dashboard takes > 7 mins, and Content Scan usually errors.

I tried a different switch, and tried updating to the current firmware v03.04.01-219. I also tried copying from Mycloud to a hard drive attached to its usb port, both by file copy & paste (no change) and by Safepoint (which I understand uses rsync, and was even slower).

Any suggestions? I see a lot on the forum and the web about various aspects of slow performance…


My guess is that it’s indexing in the background all the new files loaded onto it.  Once that’s complete respond times should come back to normal.  Indexing can take quite a while when new files are added en masse.

Thank you for answering.

Um, how many days before I can start copying files off?

Is there a way to turn off the indexing (short of the ssh I see in the forum)?

You could turn off you media service … but how long does it take to index your media files totally depends on how much data you uploaded. Mine took about a day, then the NAS performed as expected to upload, download, and have Cloud Access from the net.

Quick question – you were reporting (VERY) Slow speeds in your initial post, but I can’t make heads or tails of what and how you were measuring.  :)

7MB/minute is HORRIBLE – even slow compared to “Slow” standards.   Yes, the cloud does slow down (sometimes considerably) while indexing / thumbnail generation is going on, but I can’t imagine it slowing down that much.

Not using backup software or whatever, just try an ordinary file copy of a file that’s maybe 100 megabytes or larger.

What kind of throughput do you get then?

Also, if you’re so inclined, you can peruse this: