Very slow transfers to my MyCloud

I realize that this topic has been tackled in multiple posts, unfortunately nothing I have tried has worked. I have a MYBOOKLIVE as well as the MYCLOUD connected to the same router. Both these drives are connected at 1Gbps. The computer I am using is running Win7 and is connecting at 100Mbps. I am not concerned with maxing out the transfers only getting the MYCLOUD to be comparable witht the MYBOOKLIVE. I am attaching some screenshots I made of a transfer of the same file from the same directory once to the MYCLOUD, then to the MYBOOKLIVE. As you can see the MYCLOUD is running painfully slow, btw the content scan is currently showing idle and the front light is solid blue. Most times if I attempt to move multiple files I will eventually get a network error that the MYCLOUD can’t be found. In the 2nd network monitoring image the first section is the transfer to the MYCLOUD which I canceled, the second part (where the connection is maxed) is the transfer to the MYBOOKLIVE.

Capture2.JPG

Capture3.JPG

As you can see the connection is maxed with the MYBOOKLIVE but no where near that with the MYCLOUD. I have also switched cables and ports on the router with the same results.

Hello,

As you said, some user reported slow transfer speed on their units and some of then were able to improve their connection following the tips on the Community.

See if the tips on the following link helps to improve the transfer speed.

http://community.wd.com/t5/WD-My-Cloud/WD-My-cloud-extremely-slow/m-p/804267#M22363

I have tried the solution in that post as well as many others. I changed the UPnP setting to automatic (just checked it and it is running). This had no noticable affect (good or bad) on my transfer rate. I have, for the time being, turned off the server/streaming functions of the MyCloud, again with no change. According to the UI the content scan is IDLE.

BTW, this definitely causes the playback to be less than perfect. It is not just writing to the drive that is slow but reading from it as well. I am attempting to move most of my DVD collection to the drive so I have a one stop shop when I want to watch something. I am now in a position where I can rip my movies in a lot less time than I can move them to the NAS.

So I took a chance and did a factory restore (system only). The changes were pretty dramatic, not sure what changes I had made that caused the problem. The network traffic is still far from consistent but what took 45 minutes now takes 5.

At least I am now hitting 100% occasionally. The MYBOOKLIVE still stays maxed out for a greater percentage of time but at least this is more acceptable. Any further pointers would be much appreciated.