Very slow transfer with EX2 Ultra

Hi everyone,

I have recently bought an EX2 Ultra. For the moment, I have put a 1To Seagate IronWolf inside in JBOD (I will add another disk later to activate a RAID mode). I’m in AFP mode.

Here’s my problem, the installation has gone well, I have access to the NAS from my MacBook Pro 2019 using Wifi, but both reading and writing on the NAS are extremely slow (less than 10 Mb/s).

Can you help me to identify the cause ?

I precise that I use a SFR Box, working quite well. But I only have 4 classical LAN Ethernet plugs on it (no high speed special plug).

Thanks a lot for considering my topic.


Update (4/4/20) : Today, I have tried to connect the NAS through Windows 10, using WD Sync. The transfer speed is almost the same (less than 10 Mb/s). To connect the NAS with my router, I’m using a Cat5e ethernet cable (the one provided with the EX2 Ultra).

Some things to look at:

  1. Make sure your switch is a Gigabyte switch - 10/100 will max-out at (roughly) 10 MB/s, which is what you are seeing for speed values.

  2. Disable encryption on your EX2Ultra - that will seriously drag down performance.

Hi Krutsch,

Thank you for considering my issue.

First, I don’t have a switch but a french “box” (kind of a modem / router provided by the Internet provider you choose, connected to an Internet Access point, but also with the TV or others devices, physically or by Wifi… Just to be perfectly clear…).

I checked the specs of my “box”, and it (theoretically) must deliver a 1GB/s top transfer speed…

Concerning the encryption, I made sure that the option wasn’t selected. I can confirm that I don’t have any encryption on my disks.

But, I tried lately to add an old HDD, and switch from JBOD to RAID 0.

The speed is hardly better but acceptable for single file transfers (like a movie) for which I can reach a top 30MB/s ; when it’s time to run a 520GB backup with Time Machine, it took me 48 hours to do it… I let you do the math :sweat_smile:

So… I ordered an ethernet adapter to physically connect my MacBook Pro to my “Box”, so that I could see if the issue comes from the Wifi connection. If it doesn’t change anything, I’ll try to buy a dedicated Gigabit switch, and try again by plugging the NAS and my MacBook Pro to this switch. After that, I would be able to say if the problem comes from my “Box”.

What do you think about it ?

Let’s also talk about protocols (I’m not an expert, by far…). The AFP is switched on on My Cloud dashboard, but I saw others protocols like NFS for example. AFP (I know A is for Apple) is really the best one to use with MacOS ?
Many thanks in advance.

Any solution on your problem? Thanks!