Very Slow transfer times with My Cloud 3TB

HELP! Two problems:

  1. Connection time to the WD My Cloud from FINDER, and each time you browse takes 10 or more sec. Within the internal networks (NAS and MAC plugged directly to Router)

  2. Setting up to transfer files: “preparing to copy” time takes at least 5 min for small (under 100 Mb) and several minutes for large files (over 100 GB).

  3. Transferring files: when copying takes ages on average, if not frozen, 1 to 10 MB/sec…  

Connections and Equipment: 

I have a WD My Cloud 3TB plugged to a Netgear Nighthawk. A Macmini also plugged directly to the Netgear.

Regards and appreciate your observations!

LO

Hi and welcome to the WD Community.

Are you using the drive on gigabit environment?

Have you tried resetting the unit?

Check your end-to-end connections. 100Mbps or 1Gbps for both NAS and MacMini? Quick way is to log in to your router’s admin page and look at the link speed of each device. I’m using Nighthawk too, see the “Advanced -> Internet Port -> Show Statistics”. http://routerlogin.com/RST_statistics.htm

ERmorel… thanks. I am working with a Ge environment and I did reset the unit, same happens. So slow to prepare file transfer and also transferring files. 

In other posts few WD My Cloud Clients have fixed it by disabling UPnP and DLNA. I’ve done so as well. 

Thanks Nazar78, indeed the end-to-end connections by your direct link is 1Gbps config and running.

Do you have another pc to test the GE transfer speed? Laptop maybe? That can rule out your MacMini as the issue.

Also any changes done on your router? If yes can you try factory reset? I noticed playing with the Dynamic QoS (not WMM QoS) affects my transfer rate so it’s left disabled.

You should be getting about 80-100MB/s downloads and 60-80MB/s uploads in a GE environment with the latest firmware v4.

You might also try SMB connections instead of AFP connections…