Very slow transfer speed


The title probably isnt the most accurate, but I will describe my issue.

I run my 4TB MyCloud directly onto my gigabit wifi router. I then connect my OpenELEC box for my TV via 2.4GHz wifi. It generally runs quite well. However, when I run videos from the server via OpenELEC or even on my macbook, I get massive amounts of buffering (takes about 5-10 seconds worth every few mins) or it runs perfectly well. I have checked my wifi congestion, and the channel is quite empty. The general wifi works well. These videos are not bluray quality, but general videos.

I have disabled wdmcserverd and wdphotodnerged.

Please help!

Is your OpenELEC box an RPi? Is it up to handling video streaming?

[genuine question: I don’t know the answer, but it may be something to consider/investigate]


It’s not an rpi box. It’s a dual core unit that’s pretty capable at video playing.

I would hook the media box up with an Ethernet cable at least for testing. if it works well here it is a wifi issue which could be lots of different things

Yes, similar issue and diagnostics as here: