Very slow NAS access with Imac

I’m using the WD mybook live duo for almost one year. 
Accessing the WD through my Windows 7 PC and Windows 7 laptop was and still is fast in comparison with my new Apple iMac 27-inch: 3,2-GHz 3,2-GHz quad-core Intel Core i5.

Every time I want to access a share on the WD it cost me about 30 till 50 seconds before showing it.

When I want to access a folder or document in a share it cost a lot of time again. 
My IMac and WD are wired through 1 GB ethernet LAN ports on the same Airport Extreme. 

Using a Windows 7 VMware on the same Imac, than I can access the shares in a few seconds.

So it can not be my ethernet connection.

Even my windows 7 laptop takes about 1 to 2 seconds for the same process over wifi. 

The WD is configured as RAID 1 (stored 580 GB) 

I’m really desperate about the slow working and think about replacing this WD NAS through an other one.
But that may not be the solution.

So I hope that there is someone who has a working solution for quick accessing the WD with the IMac.


How do you access the content stored within your WD My Book Live Duo Personal Cloud Storage? Do you use SMB or AFP?

I have tried both SMB and AFP. the result is the same. Both result in a very slow connection.

in another community, someone advised me to use CIFS://MyBookLiveDuo instead of AFP or SMB.

see the link for the Dutch explanation:

The approach of the NAS is much faster now. I use Drive Mounter to mount standard shares when logging in to an acount.

If there is a better solution, please let me know. but for now this is a better solution as it was.

I have the same problem.  I have replaced thr router, replaced the ethernet cables and homeplugs - I can access the MyBookLiveDuo fine from a Windows 7 Laptop but from my iMac it is so slow to open enything or copy anything across that it is virtually uniusable.  I hoe no idea what the prpblem is and I don’t see any help I can understand or use here, although I see it’s a problem others have too.

Is there any solution to this or do I just accept that the MyLivebookDuo doesn’t work with a Mac and I will have tp take it back and swap it for another make?  Apple tell me it’s something to do with the file structure on the MBLD but if so whuy do WD sell it as Mac-compatible?

This is really, really irritating.  I have had to move my backup drive to a local USB Sumo hard drive which works fine.

Hoe het werkt op de iMac (how it works on the iMac):

 In Dutch…

  1. Open Finder.

  2. Kies “Ga” in de bovenste balk (links).

  3. Kies “Verbinden met Server”.

  4. Type cifs:// (in vele gevallen is de servernaam of het IP nummer of gewoon “WDMYCloud.local”, dus je geeft dan in: cifs://WdMyCloud.local

  5. Geef naam en wachtwoord in van de MyCloud (zoals ingevoerd bij installatie van de MyCloud.

  6. Selecteer de Volumes die je wil activeren (doorgaans allen).

  7. Finder opent nu per volume een Finder scherm. Sluit deze allemaal.

  8. In de linker kolom van finder vind je nu onder “Gedeeld” de server die je net hebt aangemaakt (zie 4 hierboven).

  9. Klik hierop en je hebt (snelle) toegang to de WD MyCloud.

  10. Open Finder

  11. Choose Go

  12. Connect to server

  13. type cifs:// plus local (this is IP address or just cifs://WdMyCloud.local)

  14. Input name and password of MyCloud

  15. Select Volumes (mostly all of them)

  16. Close Finder windows of each volume (Finder opens a window for each volume?)

  17. In Finder under Shared you will find the new Server

  18. Click on it and you have (fast) access to MyCloud.

1 Like

Thank you Menno, that worked for me.

iMac 24"

OSX 10.9.2

D-Link  DIR-605L

wireless internet connection

Hello, I have same problem. I follow your advice, it is still slow when I browsing WD NAS. Pls help

Menno, you are a genius.  Following months of slow access, after following your instructions, I now have high speed access to the WD MyCloud.  Thank you.

I have had a very similar experience to you. Using a 17inch MacBook Pro i7 quad with 8GB RAM and running Windows 7 with VMware. My LAN is 1GB Ethernet. Accessing the WD mybook live duo from the virtual Windows machine is fine. Through the Mac, using the finder, the mounting process to the WD NAS and its file shares is very slow.

Initially I had purchased the WDMBLD (6TB) to do TimeMachine backups. The drive was set for RAID 1. This drive was much worse than another NAS drive I had which was a WD My Book World (4TB). I had purchased the WDMBLD because of its larger capacity and had intended it to replace the WDMBW as the primary backup unit.

I gave up with the WD drives for backup and have replaced them with a Synology DiskStation (8TB) which works like a dream and the backups are blindingly fast. The Synology works seamlessly with the Mac OS and is backing up two Mac on the LAN.

The Western Digital units are now used for occasional external online storage with the WD MyBook Live Duo (still RAID 1) being backed up once a month by the WD MyBook World which is now configured as RAID 0.

I have only just given the “CIFS” option a go. Have not notice a remarkable difference but will persist to see if it helps.


I have the same problems: when I open a directory on the NAS it takes a lot of time (ca. 30 seconds or more) before it shows me the files and after that I have to wait more to see the thunbnails.

It’s like to jump in the floppy disk time! Awful and impossible to work!

(I tried the solutions above buy they did’t work for me)


Macbook retina 15" 2002 - Mac 10.9 - Netgear DGN1000 (direct connection NAS - Macbook works same)

I am having the same issue here as everyone else. I tried Menno’s suggestion but it is still unusably slow. Any additional suggestions? I haven’t upgraded to Sierra. I don’t know if i even want to at this point.